summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-01-18 17:39:01 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-01-18 17:39:01 +0000
commita49c801cebdfd557932cb2d9446f6422c649c94b (patch)
tree757aaf2420b0597312272db504e08695c337a6a0 /x11-drivers/xf86-video-qxl
parentAdd an XML utility function that is necessary to fix a CPU usage issue in vir... (diff)
downloadgentoo-2-a49c801cebdfd557932cb2d9446f6422c649c94b.tar.gz
gentoo-2-a49c801cebdfd557932cb2d9446f6422c649c94b.tar.bz2
gentoo-2-a49c801cebdfd557932cb2d9446f6422c649c94b.zip
spice-protocol is a set of headers and therefore is not a RDEPEND but a DEPEND. bug #381849
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-video-qxl')
-rw-r--r--x11-drivers/xf86-video-qxl/ChangeLog9
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.14.ebuild10
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.16.ebuild8
3 files changed, 16 insertions, 11 deletions
diff --git a/x11-drivers/xf86-video-qxl/ChangeLog b/x11-drivers/xf86-video-qxl/ChangeLog
index 53f1410d4b28..81ee2f1d315f 100644
--- a/x11-drivers/xf86-video-qxl/ChangeLog
+++ b/x11-drivers/xf86-video-qxl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-qxl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-qxl/ChangeLog,v 1.8 2011/09/04 12:19:16 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-qxl/ChangeLog,v 1.9 2012/01/18 17:39:01 cardoe Exp $
+
+ 18 Jan 2012; Doug Goldstein <cardoe@gentoo.org> xf86-video-qxl-0.0.14.ebuild,
+ xf86-video-qxl-0.0.16.ebuild:
+ spice-protocol is a set of headers and therefore is not a RDEPEND but a
+ DEPEND. bug #381849
04 Sep 2011; Markus Meier <maekke@gentoo.org> xf86-video-qxl-0.0.16.ebuild:
x86 stable, bug #380421
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.14.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.14.ebuild
index fa8b1a1049da..448f506c7bde 100644
--- a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.14.ebuild
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.14.ebuild,v 1.2 2011/07/16 22:48:55 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.14.ebuild,v 1.3 2012/01/18 17:39:01 cardoe Exp $
EAPI=4
inherit xorg-2
@@ -10,7 +10,7 @@ DESCRIPTION="QEMU QXL paravirt video driver"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=app-emulation/spice-protocol-0.7.0
- x11-base/xorg-server[-minimal]"
+RDEPEND="x11-base/xorg-server[-minimal]"
DEPEND="${RDEPEND}
- x11-proto/xf86dgaproto"
+ x11-proto/xf86dgaproto
+ >=app-emulation/spice-protocol-0.7.0"
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.16.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.16.ebuild
index 26d382e7e055..a38f33625ae4 100644
--- a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.16.ebuild
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.16.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.16.ebuild,v 1.4 2011/09/04 12:19:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.0.16.ebuild,v 1.5 2012/01/18 17:39:01 cardoe Exp $
EAPI=4
inherit xorg-2
@@ -11,10 +11,10 @@ KEYWORDS="amd64 x86"
IUSE="xspice"
RDEPEND="xspice? ( app-emulation/spice )
- >=app-emulation/spice-protocol-0.8.1
x11-base/xorg-server[-minimal]"
DEPEND="${RDEPEND}
- x11-proto/xf86dgaproto"
+ x11-proto/xf86dgaproto
+ >=app-emulation/spice-protocol-0.8.1"
pkg_setup() {
xorg-2_pkg_setup