summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-31 22:50:11 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-31 22:50:11 +0000
commitf72ae240e8dfa13890d2c3630d3a99216e602ba0 (patch)
treec0d071bd6ae38bf7f1641916f8931e8720d4bb27 /x11-drivers/xf86-input-wacom
parentAdd tmpfiles.setup to the boot runlevel and udev-mount to the sysinit runlevel. (diff)
downloadgentoo-2-f72ae240e8dfa13890d2c3630d3a99216e602ba0.tar.gz
gentoo-2-f72ae240e8dfa13890d2c3630d3a99216e602ba0.tar.bz2
gentoo-2-f72ae240e8dfa13890d2c3630d3a99216e602ba0.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.18.0.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 78fd58000cf9..52859fc20ae2 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.61 2012/09/29 15:11:51 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.62 2012/10/31 22:50:11 chithanh Exp $
+
+*xf86-input-wacom-0.18.0 (31 Oct 2012)
+
+ 31 Oct 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-input-wacom-0.18.0.ebuild:
+ Version bump.
*xf86-input-wacom-0.17.0 (29 Sep 2012)
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.18.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.18.0.ebuild
new file mode 100644
index 000000000000..b066c8badb09
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.18.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.18.0.ebuild,v 1.1 2012/10/31 22:50:11 chithanh Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}