summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-08-26 03:03:59 +0000
committerHanno Böck <hanno@gentoo.org>2006-08-26 03:03:59 +0000
commit1ef3573a0c3e2a95f9097ada7cdcf4046dd3b9e5 (patch)
tree454d089acd6f51da9b4df906b386ceed388acd14 /x11-drivers/linuxwacom
parentmask linuxwacom on archs not supporting linux-headers-2.6 (diff)
downloadgentoo-2-1ef3573a0c3e2a95f9097ada7cdcf4046dd3b9e5.tar.gz
gentoo-2-1ef3573a0c3e2a95f9097ada7cdcf4046dd3b9e5.tar.bz2
gentoo-2-1ef3573a0c3e2a95f9097ada7cdcf4046dd3b9e5.zip
linuxwacom version bump
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'x11-drivers/linuxwacom')
-rw-r--r--x11-drivers/linuxwacom/files/digest-linuxwacom-0.7.4_p33
-rw-r--r--x11-drivers/linuxwacom/files/linuxwacom-xorg71.diff10
-rw-r--r--x11-drivers/linuxwacom/linuxwacom-0.7.4_p3.ebuild65
3 files changed, 78 insertions, 0 deletions
diff --git a/x11-drivers/linuxwacom/files/digest-linuxwacom-0.7.4_p3 b/x11-drivers/linuxwacom/files/digest-linuxwacom-0.7.4_p3
new file mode 100644
index 000000000000..135595d118f7
--- /dev/null
+++ b/x11-drivers/linuxwacom/files/digest-linuxwacom-0.7.4_p3
@@ -0,0 +1,3 @@
+MD5 9414aa852c97b8addb32481db04be9e5 linuxwacom-0.7.4-3.tar.bz2 866312
+RMD160 789789803a31eb5b9ff1d35ef760d7d11b5c24dc linuxwacom-0.7.4-3.tar.bz2 866312
+SHA256 0f99153ba1669255e08dd7a730cf33d9766dde43f5b56ec97e6bc8ec63b60260 linuxwacom-0.7.4-3.tar.bz2 866312
diff --git a/x11-drivers/linuxwacom/files/linuxwacom-xorg71.diff b/x11-drivers/linuxwacom/files/linuxwacom-xorg71.diff
new file mode 100644
index 000000000000..9cf26d952736
--- /dev/null
+++ b/x11-drivers/linuxwacom/files/linuxwacom-xorg71.diff
@@ -0,0 +1,10 @@
+--- src/xf86Wacom.h 2006-06-19 19:42:52.000000000 +0200
++++ xf86Wacom.h 2006-06-23 23:31:44.000000000 +0200
+@@ -64,7 +64,6 @@
+ #define NEED_XF86_TYPES
+ #if !defined(DGUX)
+ #include <xf86_ansic.h>
+-#include <xisb.h>
+ #endif
+ #include <xf86_OSproc.h>
+ #include <xf86Xinput.h>
diff --git a/x11-drivers/linuxwacom/linuxwacom-0.7.4_p3.ebuild b/x11-drivers/linuxwacom/linuxwacom-0.7.4_p3.ebuild
new file mode 100644
index 000000000000..3ec06fa73cfd
--- /dev/null
+++ b/x11-drivers/linuxwacom/linuxwacom-0.7.4_p3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/linuxwacom/linuxwacom-0.7.4_p3.ebuild,v 1.1 2006/08/26 03:03:59 hanno Exp $
+
+IUSE="gtk gtk2 tcltk usb"
+
+inherit eutils
+
+DESCRIPTION="Input driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_p/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="|| ( ( x11-proto/inputproto
+ x11-base/xorg-server )
+ virtual/x11 )
+ gtk? (
+ gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ sys-libs/ncurses"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ usb? ( >=sys-kernel/linux-headers-2.6 )
+ >=sys-apps/sed-4"
+S=${WORKDIR}/${P/_p/-}
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/linuxwacom-xorg71.diff
+}
+
+src_compile() {
+ if use gtk; then
+ if use gtk2; then
+ myconf="${myconf} --with-gtk=2.0"
+ else
+ myconf="${myconf} --with-gtk=1.2"
+ fi
+ else
+ myconf="${myconf} --with-gtk=no"
+ fi
+
+ econf ${myconf} \
+ `use_with tcltk tcl` \
+ `use_with tcltk tk` \
+ --enable-wacomdrv --enable-wacdump \
+ --enable-xsetwacom --enable-dlloader || die
+
+ unset ARCH
+ emake || die "build failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed."
+ dohtml -r docs/*
+ dodoc AUTHORS ChangeLog NEWS README
+}