summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-11-21 15:45:39 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-11-21 15:45:39 +0000
commit3d4c5dd76bdea8f7190a3f9c1776e0c2e1b776b0 (patch)
treee6cba06ebedf44760f4a88737d68c24bb989f88b /x11-drivers/ati-drivers
parentkeyworded for ~ppc-macos, tested by Johan Hattne #352642 (diff)
downloadgentoo-2-3d4c5dd76bdea8f7190a3f9c1776e0c2e1b776b0.tar.gz
gentoo-2-3d4c5dd76bdea8f7190a3f9c1776e0c2e1b776b0.tar.bz2
gentoo-2-3d4c5dd76bdea8f7190a3f9c1776e0c2e1b776b0.zip
Fix installation of OpenCL on x86, bug #391249.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/ati-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog6
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-11.11.ebuild21
2 files changed, 19 insertions, 8 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index d20ab17f2dfe..c408521d230d 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-drivers/ati-drivers
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.262 2011/11/20 02:01:26 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.263 2011/11/21 15:45:39 chithanh Exp $
+
+ 21 Nov 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ ati-drivers-11.11.ebuild:
+ Fix installation of OpenCL on x86, bug #391249.
*ati-drivers-11.11 (20 Nov 2011)
diff --git a/x11-drivers/ati-drivers/ati-drivers-11.11.ebuild b/x11-drivers/ati-drivers/ati-drivers-11.11.ebuild
index 4c2209fa8dd0..5a961bffcfd0 100644
--- a/x11-drivers/ati-drivers/ati-drivers-11.11.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-11.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-11.11.ebuild,v 1.1 2011/11/20 02:01:26 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-11.11.ebuild,v 1.2 2011/11/21 15:45:39 chithanh Exp $
EAPI=4
@@ -33,7 +33,10 @@ RDEPEND="
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
- multilib? ( app-emulation/emul-linux-x86-opengl )
+ multilib? (
+ app-emulation/emul-linux-x86-opengl
+ app-emulation/emul-linux-x86-xlibs
+ )
qt4? (
x11-libs/libICE
x11-libs/libSM
@@ -46,7 +49,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}
- app-portage/portage-utils
x11-proto/inputproto
x11-proto/xf86miscproto
x11-proto/xf86vidmodeproto
@@ -264,9 +266,7 @@ pkg_setup() {
elog "r600 chipset and newer."
elog "This represent the ATI Radeon HD series at this moment."
elog
- elog "If your card is older then usage of ${CATEGORY}/xf86-video-ati"
- elog "as replacement is highly recommended. Rather than staying with"
- elog "old versions of this driver."
+ elog "If your card is older then use ${CATEGORY}/xf86-video-ati"
elog "For migration informations please reffer to:"
elog "http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml"
einfo
@@ -439,7 +439,11 @@ src_install() {
# OpenCL
if use opencl ; then
insinto /etc/OpenCL/vendors/
- doins "${ARCH_DIR}"/etc/OpenCL/vendors/amdocl64.icd || die "doins failed"
+ if [[ "${ABI}" == "amd64" ]] ; then
+ doins "${ARCH_DIR}"/etc/OpenCL/vendors/amdocl64.icd || die "doins failed"
+ else
+ doins "${ARCH_DIR}"/etc/OpenCL/vendors/amdocl32.icd || die "doins failed"
+ fi
fi
# include.
@@ -569,6 +573,9 @@ pkg_postinst() {
elog "Fully rebooting the system after an ${PN} update is recommended"
elog "Stopping Xorg, reloading fglrx kernel module and restart Xorg"
elog "might not work"
+ elog
+ elog "Some cards need acpid running to handle events"
+ elog "Please add it to boot runlevel with rc-update add acpid boot"
use modules && linux-mod_pkg_postinst
"${ROOT}"/usr/bin/eselect opengl set --use-old ati