summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHallgrimur H. Gunnarsson <hhg@gentoo.org>2004-02-28 17:37:39 +0000
committerHallgrimur H. Gunnarsson <hhg@gentoo.org>2004-02-28 17:37:39 +0000
commit99b4f5c315560dcdc7a60d0581ab1c90cb463ebd (patch)
tree771f659dc2e0f8655ea835d1cd7d0a26c52ef52e /x11-base/y-windows/y-windows-0.2.ebuild
parentnew package -- submitted by Doug Goldstein <cardoe@cardoe.com> in bug #30119 (diff)
downloadgentoo-2-99b4f5c315560dcdc7a60d0581ab1c90cb463ebd.tar.gz
gentoo-2-99b4f5c315560dcdc7a60d0581ab1c90cb463ebd.tar.bz2
gentoo-2-99b4f5c315560dcdc7a60d0581ab1c90cb463ebd.zip
new package -- submitted by Doug Goldstein <cardoe@cardoe.com> in bug #30119
Diffstat (limited to 'x11-base/y-windows/y-windows-0.2.ebuild')
-rw-r--r--x11-base/y-windows/y-windows-0.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-base/y-windows/y-windows-0.2.ebuild b/x11-base/y-windows/y-windows-0.2.ebuild
new file mode 100644
index 000000000000..9049c531cdcc
--- /dev/null
+++ b/x11-base/y-windows/y-windows-0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc., Doug Goldstein
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/y-windows/y-windows-0.2.ebuild,v 1.1 2004/02/28 17:37:29 hhg Exp $
+
+DESCRIPTION="Y Windows"
+HOMEPAGE="http://www.y-windows.org/"
+SRC_URI="http://www.cardoe.com/y-base/patches/Y-patch26.tar.bz2"
+LICENSE="GPL-2 LGPL-2 CPL-1.0"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="virtual/x11
+ >=automake-1.8
+ >=autoconf-2.58
+ >=media-libs/libsdl-1.2.0
+ >=media-libs/freetype-2.1.3
+ =dev-libs/libsigc++-1.0*
+ >=x11-libs/libiterm-mbt-0.5"
+
+S=${WORKDIR}/Y--devel--0.2--patch-26
+
+src_compile() {
+ ewarn Please wait while ./autogen.sh runs... no output will appear.
+ chmod u+x autogen.sh
+ WANT_AUTOMAKE=1.8 ./autogen.sh
+
+ econf || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die
+}
+
+pkg_postinst() {
+ ewarn Please check /etc/Y/default.conf and change your keymap to "us" if you\'re in the US.
+ echo
+ ewarn Current apps are ycalculator, yiterm, yclock, and ysample.
+ echo
+ ewarn To start Y just run startY while in X.
+}