summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-14 18:25:37 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-14 18:25:37 +0000
commitc2cbe095b087f8f4ad186f2bbb5c26306ebee908 (patch)
treebb49af051df4cb9d3f851b96d7a59b86510172fe /x11-apps
parentAdded ~amd64 keywords. Closes Bug #100042. (diff)
downloadgentoo-2-c2cbe095b087f8f4ad186f2bbb5c26306ebee908.tar.gz
gentoo-2-c2cbe095b087f8f4ad186f2bbb5c26306ebee908.tar.bz2
gentoo-2-c2cbe095b087f8f4ad186f2bbb5c26306ebee908.zip
Fix default RGB path. This should make it work by default instead of needing to set RgbPath in xorg.conf.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/rgb/ChangeLog9
-rw-r--r--x11-apps/rgb/files/digest-rgb-0.99.0-r11
-rw-r--r--x11-apps/rgb/files/rgb-path.patch19
-rw-r--r--x11-apps/rgb/rgb-0.99.0-r1.ebuild16
4 files changed, 44 insertions, 1 deletions
diff --git a/x11-apps/rgb/ChangeLog b/x11-apps/rgb/ChangeLog
index 67c36a32b45f..160fd69de885 100644
--- a/x11-apps/rgb/ChangeLog
+++ b/x11-apps/rgb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/rgb
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/rgb/ChangeLog,v 1.2 2005/08/08 20:14:18 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/rgb/ChangeLog,v 1.3 2005/08/14 18:25:37 spyderous Exp $
+
+*rgb-0.99.0-r1 (14 Aug 2005)
+
+ 14 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/rgb-path.patch, +rgb-0.99.0-r1.ebuild:
+ Fix default RGB path. This should make it work by default instead of needing
+ to set RgbPath in xorg.conf.
08 Aug 2005; Ferris McCormick <fmccor@gentoo.org> rgb-0.99.0.ebuild:
Add ~sparc keyword (Modular X testing).
diff --git a/x11-apps/rgb/files/digest-rgb-0.99.0-r1 b/x11-apps/rgb/files/digest-rgb-0.99.0-r1
new file mode 100644
index 000000000000..05b3ed4bb4b1
--- /dev/null
+++ b/x11-apps/rgb/files/digest-rgb-0.99.0-r1
@@ -0,0 +1 @@
+MD5 f893387b619394707e83a4118ca484a1 rgb-0.99.0.tar.bz2 63928
diff --git a/x11-apps/rgb/files/rgb-path.patch b/x11-apps/rgb/files/rgb-path.patch
new file mode 100644
index 000000000000..cfd2ffc6bd27
--- /dev/null
+++ b/x11-apps/rgb/files/rgb-path.patch
@@ -0,0 +1,19 @@
+Index: configure.ac
+===================================================================
+RCS file: /cvs/xorg/app/rgb/configure.ac,v
+retrieving revision 1.3
+retrieving revision 1.4
+diff -u -b -B -r1.3 -r1.4
+--- configure.ac 29 Jul 2005 21:22:30 -0000 1.3
++++ configure.ac 1 Aug 2005 22:35:37 -0000 1.4
+@@ -40,8 +40,8 @@
+ AC_MSG_CHECKING([for rgb database location])
+ AC_ARG_WITH([rgb-db-dir],
+ AC_HELP_STRING([--with-rgb-db=<path>],
+- [rgb database location (default is libdir/rgb)]),
+- [db_path=$withval], [db_path=$libdir/rgb])
++ [rgb database location (default is libdir/X11/rgb)]),
++ [db_path=$withval], [db_path=$libdir/X11/rgb])
+ AC_MSG_RESULT([$db_path])
+ dnl XXX not working - AC_DEFINE([RGB_DB], $db_path, [set to location of rgb database (without any file type suffix)])
+ db_file=`basename $db_path`
diff --git a/x11-apps/rgb/rgb-0.99.0-r1.ebuild b/x11-apps/rgb/rgb-0.99.0-r1.ebuild
new file mode 100644
index 000000000000..67791caa8ea0
--- /dev/null
+++ b/x11-apps/rgb/rgb-0.99.0-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/rgb/rgb-0.99.0-r1.ebuild,v 1.1 2005/08/14 18:25:37 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+SNAPSHOT="yes"
+
+inherit x-modular
+
+PATCHES="${FILESDIR}/rgb-path.patch"
+
+DESCRIPTION="X.Org rgb application"
+KEYWORDS="~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"