summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-28 22:52:28 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-28 22:52:28 +0000
commit6e3a145679f764057dab1632cc4200180ecbe3cc (patch)
tree73015e7f693e583b63e6fc441c25e7f340c35987 /x11-apps
parentFix wrapper script to not to rely on debian-specifix way to detect libexec.. (diff)
downloadgentoo-2-6e3a145679f764057dab1632cc4200180ecbe3cc.tar.gz
gentoo-2-6e3a145679f764057dab1632cc4200180ecbe3cc.tar.bz2
gentoo-2-6e3a145679f764057dab1632cc4200180ecbe3cc.zip
Add fix from upstream for building w/clang.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/intel-gpu-tools/ChangeLog6
-rw-r--r--x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.10-clang.patch44
-rw-r--r--x11-apps/intel-gpu-tools/intel-gpu-tools-1.10.ebuild4
3 files changed, 52 insertions, 2 deletions
diff --git a/x11-apps/intel-gpu-tools/ChangeLog b/x11-apps/intel-gpu-tools/ChangeLog
index 8ff83c75a7f5..c32070d2214f 100644
--- a/x11-apps/intel-gpu-tools/ChangeLog
+++ b/x11-apps/intel-gpu-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-apps/intel-gpu-tools
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/ChangeLog,v 1.23 2015/04/10 12:26:47 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/ChangeLog,v 1.24 2015/05/28 22:52:28 vapier Exp $
+
+ 28 May 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/intel-gpu-tools-1.10-clang.patch, intel-gpu-tools-1.10.ebuild:
+ Add fix from upstream for building w/clang.
*intel-gpu-tools-1.10 (10 Apr 2015)
diff --git a/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.10-clang.patch b/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.10-clang.patch
new file mode 100644
index 000000000000..2f7b7a2c1ba1
--- /dev/null
+++ b/x11-apps/intel-gpu-tools/files/intel-gpu-tools-1.10-clang.patch
@@ -0,0 +1,44 @@
+fix from upstream for building w/clang
+
+From 95019c2a3c4ed5943ad16e17c8dcf36fd6492adc Mon Sep 17 00:00:00 2001
+From: Yunlian Jiang <yunlian@google.com>
+Date: Tue, 26 May 2015 10:22:31 -0700
+Subject: [PATCH] debugger: remove unnecessary struct per_thread_data
+
+This removes unnecessary 'struct per_thread_data' and avoids the
+compilation error 'variable length array in structure extension
+will never be supported' by clang. The bug entry is
+https://code.google.com/p/chromium/issues/detail?id=476001
+
+Cc: Benjamin Widawsky <benjamin.widawsky@intel.com>
+Cc: Thomas Wood <thomas.wood@intel.com>
+Signed-off-by: Yunlian Jiang <yunlian@google.com>
+Signed-off-by: Thomas Wood <thomas.wood@intel.com>
+---
+ debugger/eudb.c | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/debugger/eudb.c b/debugger/eudb.c
+index 0e810db..39c5cca 100644
+--- a/debugger/eudb.c
++++ b/debugger/eudb.c
+@@ -207,15 +207,11 @@ wait_for_attn(int timeout, int *out_bits) {
+ #define eu_tid(bit) eu_info->debuggees[bit].tid
+ static struct eu_state *
+ find_eu_shmem(int bit, volatile uint8_t *buf) {
+- struct per_thread_data {
+- uint8_t ____[dh.per_thread_scratch];
+- }__attribute__((packed)) *data;
+ struct eu_state *eu;
+ int mem_tid, mem_euid, i;
+
+- data = (struct per_thread_data *)buf;
+ for(i = 0; i < eu_info->num_threads; i++) {
+- eu = (struct eu_state *)&data[i];
++ eu = (struct eu_state *)(buf + i * dh.per_thread_scratch);
+ mem_tid = eu->sr0 & 0x7;
+ mem_euid = (eu->sr0 >> 8) & 0xf;
+ if (mem_tid == eu_tid(bit) && mem_euid == eu_id(bit))
+--
+2.4.1
+
diff --git a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.10.ebuild b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.10.ebuild
index 30d9a91bb370..10ebdc51bec4 100644
--- a/x11-apps/intel-gpu-tools/intel-gpu-tools-1.10.ebuild
+++ b/x11-apps/intel-gpu-tools/intel-gpu-tools-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/intel-gpu-tools-1.10.ebuild,v 1.1 2015/04/10 12:26:47 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/intel-gpu-tools/intel-gpu-tools-1.10.ebuild,v 1.2 2015/05/28 22:52:28 vapier Exp $
EAPI=5
@@ -21,6 +21,8 @@ DEPEND="dev-libs/glib:2
python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-clang.patch" )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}