summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-07-16 16:44:02 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-07-16 16:44:02 +0000
commitb6721afac3de64e0cbdd59c654e5f7bfd649b44f (patch)
tree78048aacfa70f8df0bd3f45e156526a920b26fe9 /x11-apps/xdriinfo
parentAdded ~hppa (diff)
downloadgentoo-2-b6721afac3de64e0cbdd59c654e5f7bfd649b44f.tar.gz
gentoo-2-b6721afac3de64e0cbdd59c654e5f7bfd649b44f.tar.bz2
gentoo-2-b6721afac3de64e0cbdd59c654e5f7bfd649b44f.zip
Switch to the xorg-x11 OpenGL header implementation for the compile. (Bug
#138920, reported by Alexander) (Portage version: 2.1.1_pre3)
Diffstat (limited to 'x11-apps/xdriinfo')
-rw-r--r--x11-apps/xdriinfo/ChangeLog7
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.1.ebuild15
2 files changed, 20 insertions, 2 deletions
diff --git a/x11-apps/xdriinfo/ChangeLog b/x11-apps/xdriinfo/ChangeLog
index 8d22e7031fcd..3316f9e36946 100644
--- a/x11-apps/xdriinfo/ChangeLog
+++ b/x11-apps/xdriinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdriinfo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.20 2006/07/11 01:35:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.21 2006/07/16 16:44:02 joshuabaergen Exp $
+
+ 16 Jul 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ xdriinfo-1.0.1.ebuild:
+ Switch to the xorg-x11 OpenGL header implementation for the compile. (Bug
+ #138920, reported by Alexander)
11 Jul 2006; Aron Griffis <agriffis@gentoo.org> xdriinfo-1.0.1.ebuild:
Mark 1.0.1 stable on ia64
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.1.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.1.ebuild
index e9a684b2e11f..44ecc5496b89 100644
--- a/x11-apps/xdriinfo/xdriinfo-1.0.1.ebuild
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/xdriinfo-1.0.1.ebuild,v 1.7 2006/07/11 01:35:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/xdriinfo-1.0.1.ebuild,v 1.8 2006/07/16 16:44:02 joshuabaergen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -13,4 +13,17 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
RDEPEND="x11-libs/libX11
virtual/opengl"
DEPEND="${RDEPEND}
+ app-admin/eselect-opengl
x11-proto/glproto"
+
+pkg_setup() {
+ # Bug #138920
+ ewarn "Forcing on xorg-x11 for header sanity..."
+ OLD_IMPLEM="$(eselect opengl show)"
+ eselect opengl set --impl-headers xorg-x11
+}
+
+pkg_postinst() {
+ echo
+ eselect opengl set ${OLD_IMPLEM}
+}