summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-09-22 18:35:00 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-09-22 18:35:00 +0000
commit3b6e83baaa231ed6dcb1bb8553d5549baef0ac04 (patch)
treedcec6d8c7d9d8219622512fcd50fd78d0537fffb /www-servers
parentFix license (diff)
downloadgentoo-2-3b6e83baaa231ed6dcb1bb8553d5549baef0ac04.tar.gz
gentoo-2-3b6e83baaa231ed6dcb1bb8553d5549baef0ac04.tar.bz2
gentoo-2-3b6e83baaa231ed6dcb1bb8553d5549baef0ac04.zip
Version bump.
(Portage version: 2.2.0_alpha51_p7/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/gunicorn-0.13.2.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index 523d5363a6bf..557dbb02bb45 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.10 2011/08/22 15:19:03 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.11 2011/09/22 18:35:00 rafaelmartins Exp $
+
+*gunicorn-0.13.2 (22 Sep 2011)
+
+ 22 Sep 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-0.13.2.ebuild:
+ Version bump.
*gunicorn-0.13.1 (22 Aug 2011)
diff --git a/www-servers/gunicorn/gunicorn-0.13.2.ebuild b/www-servers/gunicorn/gunicorn-0.13.2.ebuild
new file mode 100644
index 000000000000..30ad24939a20
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-0.13.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.13.2.ebuild,v 1.1 2011/09/22 18:35:00 rafaelmartins Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX, fast clients and nothing else"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools
+ test? ( dev-python/nose )"
+
+# tests are failing randomly.
+RESTRICT="test"
+
+DOCS="README.rst"
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r doc/htdocs/*
+ insinto "/usr/share/doc/${PF}"
+ use examples && doins -r examples
+}
+
+src_test() {
+ # distutils_src_test doesn't works if gunicorn isn't installed yet
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
+ }
+ python_execute_function testing
+}