summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2007-04-19 09:33:11 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2007-04-19 09:33:11 +0000
commit418923681fb5e63d6924a29bbfd67a291c47e452 (patch)
treea17184f4ecab61976235363bc3507b04f94da210 /www-servers/bozohttpd
parentversion bump. Improved initscript thanks to inspiration by Natanael Copa in b... (diff)
downloadgentoo-2-418923681fb5e63d6924a29bbfd67a291c47e452.tar.gz
gentoo-2-418923681fb5e63d6924a29bbfd67a291c47e452.tar.bz2
gentoo-2-418923681fb5e63d6924a29bbfd67a291c47e452.zip
Version bump + modifications not to depend on hardcoded /bin/install; see bug #171035
(Portage version: 2.1.2.2)
Diffstat (limited to 'www-servers/bozohttpd')
-rw-r--r--www-servers/bozohttpd/ChangeLog10
-rw-r--r--www-servers/bozohttpd/bozohttpd-20040823.ebuild16
-rw-r--r--www-servers/bozohttpd/bozohttpd-20050410.ebuild16
-rw-r--r--www-servers/bozohttpd/bozohttpd-20060517.ebuild41
-rw-r--r--www-servers/bozohttpd/files/bozohttpd-20050410.Makefile34
-rw-r--r--www-servers/bozohttpd/files/bozohttpd.Makefile34
-rw-r--r--www-servers/bozohttpd/files/digest-bozohttpd-200605173
7 files changed, 67 insertions, 87 deletions
diff --git a/www-servers/bozohttpd/ChangeLog b/www-servers/bozohttpd/ChangeLog
index 1c1fd0fe49a9..daceb032d0a4 100644
--- a/www-servers/bozohttpd/ChangeLog
+++ b/www-servers/bozohttpd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/bozohttpd
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/ChangeLog,v 1.6 2007/04/01 13:07:06 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/ChangeLog,v 1.7 2007/04/19 09:33:11 s4t4n Exp $
+
+*bozohttpd-20060517 (19 Apr 2007)
+
+ 19 Apr 2007; Michele Noberasco <s4t4n@gentoo.org> bozohttpd-20060517.ebuild:
+ Version bump, see bug #171035.
+ bozohttpd-20050410.ebuild, bozohttpd-20040823.ebuild:
+ Update Makefile and installation handling so that there is no dependancy on hardcoded
+ /bin/install
01 Apr 2007; Thilo Bangert <bangert@gentoo.org>
files/bozohttpd-20050410.Makefile:
diff --git a/www-servers/bozohttpd/bozohttpd-20040823.ebuild b/www-servers/bozohttpd/bozohttpd-20040823.ebuild
index 36e0fdbf3246..3f241bd1e831 100644
--- a/www-servers/bozohttpd/bozohttpd-20040823.ebuild
+++ b/www-servers/bozohttpd/bozohttpd-20040823.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20040823.ebuild,v 1.2 2005/09/16 07:06:28 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20040823.ebuild,v 1.3 2007/04/19 09:33:11 s4t4n Exp $
inherit eutils
@@ -16,11 +16,10 @@ DEPEND=">=dev-libs/openssl-0.9.7d-r1"
src_unpack()
{
unpack ${A}
-
- # We substitute the Makefile because the original works only with BSD make
cd ${S}
- rm -f Makefile
- cp ${FILESDIR}/${PN}.Makefile Makefile
+
+ # Rename Makefile
+ mv Makefile.boot Makefile
# Apparently, support for '-a' cmd line arg was removed, but left in
# 'bozohpptd -h' explanations
@@ -29,9 +28,8 @@ src_unpack()
src_install ()
{
- dodir usr/bin
- dodir usr/share/man
- PREFIX="${D}/usr" einstall || die
+ dobin bozohttpd
+ doman bozohttpd.8
insinto /etc/conf.d; newins ${FILESDIR}/${PN}.conffile bozohttpd
exeinto /etc/init.d; newexe ${FILESDIR}/${PN}.initscript bozohttpd
diff --git a/www-servers/bozohttpd/bozohttpd-20050410.ebuild b/www-servers/bozohttpd/bozohttpd-20050410.ebuild
index d3c9515e8cc5..ac45190e0d8c 100644
--- a/www-servers/bozohttpd/bozohttpd-20050410.ebuild
+++ b/www-servers/bozohttpd/bozohttpd-20050410.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20050410.ebuild,v 1.1 2005/09/16 07:06:28 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20050410.ebuild,v 1.2 2007/04/19 09:33:11 s4t4n Exp $
inherit eutils
@@ -16,18 +16,16 @@ DEPEND=">=dev-libs/openssl-0.9.7d-r1"
src_unpack()
{
unpack ${A}
-
- # We substitute the Makefile because the original works only with BSD make
cd ${S}
- rm -f Makefile
- cp ${FILESDIR}/${P}.Makefile Makefile
+
+ # Rename Makefile
+ mv Makefile.boot Makefile
}
src_install ()
{
- dodir usr/bin
- dodir usr/share/man
- PREFIX="${D}/usr" einstall || die
+ dobin bozohttpd
+ doman bozohttpd.8
insinto /etc/conf.d; newins ${FILESDIR}/${PN}.conffile bozohttpd
exeinto /etc/init.d; newexe ${FILESDIR}/${PN}.initscript bozohttpd
diff --git a/www-servers/bozohttpd/bozohttpd-20060517.ebuild b/www-servers/bozohttpd/bozohttpd-20060517.ebuild
new file mode 100644
index 000000000000..70b71c6e1230
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20060517.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20060517.ebuild,v 1.1 2007/04/19 09:33:11 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-libs/openssl-0.9.8d
+ >=sys-apps/sed-4.1.5"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Rename Makefile
+ mv Makefile.boot Makefile
+
+ # Make it honour Gentoo CFLAGS
+ sed -ie "s/-O/${CFLAGS}/" Makefile
+}
+
+src_install ()
+{
+ dobin bozohttpd
+ doman bozohttpd.8
+
+ insinto /etc/conf.d; newins ${FILESDIR}/${PN}.conffile bozohttpd
+ exeinto /etc/init.d; newexe ${FILESDIR}/${PN}.initscript bozohttpd
+}
+
+pkg_postinst()
+{
+ einfo "Remember to edit /etc/conf.d/bozohttpd to suit your needs."
+}
diff --git a/www-servers/bozohttpd/files/bozohttpd-20050410.Makefile b/www-servers/bozohttpd/files/bozohttpd-20050410.Makefile
deleted file mode 100644
index 035d36f7c01f..000000000000
--- a/www-servers/bozohttpd/files/bozohttpd-20050410.Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-ifndef MANDIR
- MANDIR = share/man/man8
-endif
-ifndef PREFIX
- PREFIX = /usr/local
-endif
-ifndef CC
- CC = gcc
-endif
-ifndef INSTALL
- INSTALL = /bin/install
-endif
-
-SRCS = bozohttpd.c auth-bozo.c cgi-bozo.c content-bozo.c daemon-bozo.c dir-index-bozo.c ssl-bozo.c tilde-luzah-bozo.c
-OBJ = bozohttpd
-
-all: bozohttpd
-
-bozohttpd:
- $(CC) $(CFLAGS) -o $(OBJ) $(SRCS) -lssl -lcrypto
-
-clean:
- rm -f $(OBJ)
- rm -f *~
-
-install:: bozohttpd
- mkdir -p $(PREFIX)/bin
- $(INSTALL) -s -m 755 $(OBJ) $(PREFIX)/bin
- $(INSTALL) -d $(PREFIX)/$(MANDIR)
- $(INSTALL) -m 644 $(OBJ).8 $(PREFIX)/$(MANDIR)
-
-uninstall::
- -rm -f $(PREFIX)/bin/$(OBJ)
- -rm -f $(PREFIX)/$(MANDIR)/$(OBJ).8
diff --git a/www-servers/bozohttpd/files/bozohttpd.Makefile b/www-servers/bozohttpd/files/bozohttpd.Makefile
deleted file mode 100644
index 6259c3a2a71a..000000000000
--- a/www-servers/bozohttpd/files/bozohttpd.Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-ifndef MANDIR
- MANDIR = share/man/man8
-endif
-ifndef PREFIX
- PREFIX = /usr/local
-endif
-ifndef CC
- CC = gcc
-endif
-ifndef INSTALL
- INSTALL = /bin/install
-endif
-
-SRCS = bozohttpd.c
-OBJ = bozohttpd
-
-all: bozohttpd
-
-bozohttpd:
- $(CC) $(CFLAGS) -o $(OBJ) $(SRCS) -lssl -lcrypto
-
-clean:
- rm -f $(OBJ)
- rm -f *~
-
-install:: bozohttpd
- mkdir -p $(PREFIX)/bin
- $(INSTALL) -s -m 755 $(OBJ) $(PREFIX)/bin
- $(INSTALL) -d $(PREFIX)/$(MANDIR)
- $(INSTALL) -m 644 $(OBJ).8 $(PREFIX)/$(MANDIR)
-
-uninstall::
- -rm -f $(PREFIX)/bin/$(OBJ)
- -rm -f $(PREFIX)/$(MANDIR)/$(OBJ).8
diff --git a/www-servers/bozohttpd/files/digest-bozohttpd-20060517 b/www-servers/bozohttpd/files/digest-bozohttpd-20060517
new file mode 100644
index 000000000000..b28a23f9d6f8
--- /dev/null
+++ b/www-servers/bozohttpd/files/digest-bozohttpd-20060517
@@ -0,0 +1,3 @@
+MD5 75b9b57bb56ecdbfac2f5d024080b226 bozohttpd-20060517.tar.bz2 33032
+RMD160 edf15fe2998ca2fae0035f8380639e8741d0406a bozohttpd-20060517.tar.bz2 33032
+SHA256 6b87c6d762f0100e0c32eb5fbd7ac33ab174ee7646a9b6787b9a79bf1f739bff bozohttpd-20060517.tar.bz2 33032