summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-04-26 09:00:26 +0000
committerAlex Alexander <wired@gentoo.org>2010-04-26 09:00:26 +0000
commite8b1d2b3374d63ee695a877a02aeeda8c7e3ec22 (patch)
tree0a2dfa91a791e16c7f84f3e5ecdab28a086d3261 /www-misc
parentx86 stable wrt bug #314943 (diff)
downloadgentoo-2-e8b1d2b3374d63ee695a877a02aeeda8c7e3ec22.tar.gz
gentoo-2-e8b1d2b3374d63ee695a877a02aeeda8c7e3ec22.tar.bz2
gentoo-2-e8b1d2b3374d63ee695a877a02aeeda8c7e3ec22.zip
revbump that actually works thanks to Daniel (billie)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/surl/ChangeLog8
-rw-r--r--www-misc/surl/surl-0.7.0-r1.ebuild27
-rw-r--r--www-misc/surl/surl-0.7.0.ebuild23
3 files changed, 34 insertions, 24 deletions
diff --git a/www-misc/surl/ChangeLog b/www-misc/surl/ChangeLog
index f0815d95fe1b..14a874c26914 100644
--- a/www-misc/surl/ChangeLog
+++ b/www-misc/surl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/surl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/surl/ChangeLog,v 1.1 2010/04/25 13:40:58 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/surl/ChangeLog,v 1.2 2010/04/26 09:00:26 wired Exp $
+
+*surl-0.7.0-r1 (26 Apr 2010)
+
+ 26 Apr 2010; Alex Alexander <wired@gentoo.org> -surl-0.7.0.ebuild,
+ +surl-0.7.0-r1.ebuild:
+ revbump that actually works thanks to Daniel (billie)
*surl-0.7.0 (25 Apr 2010)
diff --git a/www-misc/surl/surl-0.7.0-r1.ebuild b/www-misc/surl/surl-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..806c801e70e1
--- /dev/null
+++ b/www-misc/surl/surl-0.7.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/surl/surl-0.7.0-r1.ebuild,v 1.1 2010/04/26 09:00:26 wired Exp $
+
+EAPI=3
+PYTHON_DEPEND=2
+
+inherit distutils
+
+DESCRIPTION="URL shortening command line application that supports various sites."
+HOMEPAGE="http://launchpad.net/surl"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV%.*}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc AUTHORS.txt || die "doc install failed"
+}
diff --git a/www-misc/surl/surl-0.7.0.ebuild b/www-misc/surl/surl-0.7.0.ebuild
deleted file mode 100644
index 6ad9854160f3..000000000000
--- a/www-misc/surl/surl-0.7.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/surl/surl-0.7.0.ebuild,v 1.1 2010/04/25 13:40:58 wired Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-inherit python
-
-DESCRIPTION="surl is a URL shortening command line application that supports various sites."
-HOMEPAGE="http://launchpad.net/surl"
-SRC_URI="http://launchpad.net/${PN}/trunk/0.7/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_install() {
- dobin surl.py || die "installation failed"
-
- dodoc AUTHORS.txt ChangeLog.txt || die "doc installation failed"
-}