summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-02 10:40:49 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-02 10:40:49 +0000
commitb534bcbacf0326aabf3aef27d64c94a1ce3bab04 (patch)
tree1a48097a20e4de61c5cb5f94025182a0eb65ea1f /www-misc
parentIntroduce multilib support, bug #499390. (diff)
downloadgentoo-2-b534bcbacf0326aabf3aef27d64c94a1ce3bab04.tar.gz
gentoo-2-b534bcbacf0326aabf3aef27d64c94a1ce3bab04.tar.bz2
gentoo-2-b534bcbacf0326aabf3aef27d64c94a1ce3bab04.zip
Fix unit file and automagic installation of them (#508914 by Alex Xu)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/fcgiwrap/ChangeLog9
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.1.0-r1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/www-misc/fcgiwrap/ChangeLog b/www-misc/fcgiwrap/ChangeLog
index 947ad53d6391..1df4eae0829d 100644
--- a/www-misc/fcgiwrap/ChangeLog
+++ b/www-misc/fcgiwrap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/fcgiwrap
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.15 2013/10/13 10:19:57 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.16 2014/05/02 10:40:49 pacho Exp $
+
+*fcgiwrap-1.1.0-r1 (02 May 2014)
+
+ 02 May 2014; Pacho Ramos <pacho@gentoo.org> +fcgiwrap-1.1.0-r1.ebuild:
+ Fix unit file and automagic installation of them (#508914 by Alex Xu)
13 Oct 2013; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
Updated Nikoli's e-mail address for easier automatic assignment.
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.1.0-r1.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..e29ef3d5e1c7
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-1.1.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-1.1.0-r1.ebuild,v 1.1 2014/05/02 10:40:49 pacho Exp $
+
+EAPI="5"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit autotools systemd toolchain-funcs ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="systemd"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/gnosek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="dev-libs/fcgi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README.rst )
+
+src_prepare() {
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+ tc-export CC
+
+ # Fix systemd units for Gentoo
+ sed -i -e '/User/d' systemd/fcgiwrap.service || die
+ sed -i -e '/Group/d' systemd/fcgiwrap.service || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with systemd) \
+ "$(systemd_with_unitdir)"
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}