summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-22 15:39:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-22 15:39:18 +0000
commit861232d4861494375ec578f95d567d5990fd30be (patch)
treef639ccef32d139e1225292117bdb6176ac6a3c93 /www-misc
parentrm (diff)
downloadgentoo-2-861232d4861494375ec578f95d567d5990fd30be.tar.gz
gentoo-2-861232d4861494375ec578f95d567d5990fd30be.tar.bz2
gentoo-2-861232d4861494375ec578f95d567d5990fd30be.zip
Fix building with jpeg-8 (previous declaration of jpeg_mem_src and jpeg_mem_dest) wrt #305201, thanks to Alex. P. Burlutsky for patch.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/zoneminder/ChangeLog9
-rw-r--r--www-misc/zoneminder/files/1.24.2/zm_jpeg.patch59
-rw-r--r--www-misc/zoneminder/zoneminder-1.24.2.ebuild7
3 files changed, 70 insertions, 5 deletions
diff --git a/www-misc/zoneminder/ChangeLog b/www-misc/zoneminder/ChangeLog
index 42e415e544eb..96efb3902889 100644
--- a/www-misc/zoneminder/ChangeLog
+++ b/www-misc/zoneminder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/zoneminder
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/ChangeLog,v 1.37 2009/09/16 11:58:25 tanderson Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/ChangeLog,v 1.38 2010/02/22 15:39:18 ssuominen Exp $
+
+ 22 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +files/1.24.2/zm_jpeg.patch, zoneminder-1.24.2.ebuild:
+ Fix building with jpeg-8 (previous declaration of jpeg_mem_src and
+ jpeg_mem_dest) wrt #305201, thanks to Alex. P. Burlutsky for patch.
16 Sep 2009; Thomas Anderson <tanderson@gentoo.org> metadata.xml:
Fix email address.
diff --git a/www-misc/zoneminder/files/1.24.2/zm_jpeg.patch b/www-misc/zoneminder/files/1.24.2/zm_jpeg.patch
new file mode 100644
index 000000000000..4d3dbaddc793
--- /dev/null
+++ b/www-misc/zoneminder/files/1.24.2/zm_jpeg.patch
@@ -0,0 +1,59 @@
+diff -ur ZoneMinder-1.24.2.orig/src/zm_image.cpp ZoneMinder-1.24.2/src/zm_image.cpp
+--- ZoneMinder-1.24.2.orig/src/zm_image.cpp 2009-05-25 21:04:00.000000000 +0300
++++ ZoneMinder-1.24.2/src/zm_image.cpp 2010-02-22 17:43:14.000000000 +0200
+@@ -461,7 +461,7 @@
+ return( false );
+ }
+
+- jpeg_mem_src( cinfo, inbuffer, inbuffer_size );
++ zm_jpeg_mem_src( cinfo, inbuffer, inbuffer_size );
+
+ jpeg_read_header( cinfo, TRUE );
+
+@@ -523,7 +523,7 @@
+ jpeg_create_compress( cinfo );
+ }
+
+- jpeg_mem_dest( cinfo, outbuffer, outbuffer_size );
++ zm_jpeg_mem_dest( cinfo, outbuffer, outbuffer_size );
+
+ cinfo->image_width = width; /* image width and height, in pixels */
+ cinfo->image_height = height;
+diff -ur ZoneMinder-1.24.2.orig/src/zm_jpeg.c ZoneMinder-1.24.2/src/zm_jpeg.c
+--- ZoneMinder-1.24.2.orig/src/zm_jpeg.c 2009-03-20 14:07:00.000000000 +0200
++++ ZoneMinder-1.24.2/src/zm_jpeg.c 2010-02-22 17:43:14.000000000 +0200
+@@ -173,7 +173,7 @@
+ * for closing it after finishing compression.
+ */
+
+-void jpeg_mem_dest (j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size )
++void zm_jpeg_mem_dest (j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size )
+ {
+ mem_dest_ptr dest;
+
+@@ -350,12 +350,12 @@
+ * for closing it after finishing decompression.
+ */
+
+-void jpeg_mem_src( j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size )
++void zm_jpeg_mem_src( j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size )
+ {
+ mem_src_ptr src;
+
+ /* The source object and input buffer are made permanent so that a series
+- * of JPEG images can be read from the same file by calling jpeg_mem_src
++ * of JPEG images can be read from the same file by calling zm_jpeg_mem_src
+ * only before the first one. (If we discarded the buffer at the end of
+ * one image, we'd likely lose the start of the next one.)
+ * This makes it unsafe to use this manager and a different source
+diff -ur ZoneMinder-1.24.2.orig/src/zm_jpeg.h ZoneMinder-1.24.2/src/zm_jpeg.h
+--- ZoneMinder-1.24.2.orig/src/zm_jpeg.h 2009-03-20 14:07:00.000000000 +0200
++++ ZoneMinder-1.24.2/src/zm_jpeg.h 2010-02-22 17:43:14.000000000 +0200
+@@ -36,5 +36,5 @@
+ void zm_jpeg_emit_message( j_common_ptr cinfo, int msg_level );
+
+ // Prototypes for memory compress/decompression object */
+-void jpeg_mem_src(j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size );
+-void jpeg_mem_dest(j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size );
++void zm_jpeg_mem_src(j_decompress_ptr cinfo, const JOCTET *inbuffer, int inbuffer_size );
++void zm_jpeg_mem_dest(j_compress_ptr cinfo, JOCTET *outbuffer, int *outbuffer_size );
diff --git a/www-misc/zoneminder/zoneminder-1.24.2.ebuild b/www-misc/zoneminder/zoneminder-1.24.2.ebuild
index a38b72f888b8..7a58b6dc23eb 100644
--- a/www-misc/zoneminder/zoneminder-1.24.2.ebuild
+++ b/www-misc/zoneminder/zoneminder-1.24.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/zoneminder-1.24.2.ebuild,v 1.1 2009/08/03 11:19:59 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/zoneminder-1.24.2.ebuild,v 1.2 2010/02/22 15:39:18 ssuominen Exp $
inherit eutils autotools depend.php depend.apache multilib
@@ -49,7 +49,7 @@ RDEPEND="dev-perl/DBD-mysql
need_apache
need_php_httpd
-S="${WORKDIR}"/${MY_PN}-${MY_PV}
+S=${WORKDIR}/${MY_PN}-${MY_PV}
pkg_setup() {
require_php_with_use mysql sockets apache2
@@ -63,6 +63,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PATCH_PV}/zm_create.sql.in.patch
epatch "${FILESDIR}"/${PATCH_PV}/zm_remote_camera_http.patch
epatch "${FILESDIR}"/${PATCH_PV}/db_upgrade_script_location.patch
+ epatch "${FILESDIR}"/${PATCH_PV}/zm_jpeg.patch
eautoreconf
}