summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-05-31 04:14:40 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-05-31 04:14:40 +0000
commite3251ff4ae21ceaa75f24a56fe34f83b17f26fee (patch)
treead05221a9b40493ec77899198becf9cbadb51a84 /www-client
parentbump; drop py2.6 pypy2_0 support (diff)
downloadgentoo-2-e3251ff4ae21ceaa75f24a56fe34f83b17f26fee.tar.gz
gentoo-2-e3251ff4ae21ceaa75f24a56fe34f83b17f26fee.tar.bz2
gentoo-2-e3251ff4ae21ceaa75f24a56fe34f83b17f26fee.zip
fixed parallel make issue (bug 461014); added live ebuild as upstream has been fairly active since last release
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/elinks/ChangeLog9
-rw-r--r--www-client/elinks/elinks-0.12_pre6.ebuild10
-rw-r--r--www-client/elinks/elinks-9999.ebuild150
-rw-r--r--www-client/elinks/files/elinks-9999-parallel-make.patch51
4 files changed, 216 insertions, 4 deletions
diff --git a/www-client/elinks/ChangeLog b/www-client/elinks/ChangeLog
index 804cd75feace..b946f4b0bb99 100644
--- a/www-client/elinks/ChangeLog
+++ b/www-client/elinks/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/elinks
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/ChangeLog,v 1.168 2014/03/09 01:58:04 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/ChangeLog,v 1.169 2014/05/31 04:14:40 axs Exp $
+
+*elinks-9999 (31 May 2014)
+
+ 31 May 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> +elinks-9999.ebuild,
+ +files/elinks-9999-parallel-make.patch, elinks-0.12_pre6.ebuild:
+ fixed parallel make issue (bug 461014); added live ebuild as upstream has been
+ fairly active since last release
09 Mar 2014; Manuel Rüger <mrueg@gentoo.org> -elinks-0.11.7.ebuild,
-elinks-0.12_pre5-r2.ebuild, -files/elinks-0.10.1-utf_8_io-default.patch,
diff --git a/www-client/elinks/elinks-0.12_pre6.ebuild b/www-client/elinks/elinks-0.12_pre6.ebuild
index e39ecacc6363..e871b4c98307 100644
--- a/www-client/elinks/elinks-0.12_pre6.ebuild
+++ b/www-client/elinks/elinks-0.12_pre6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.12_pre6.ebuild,v 1.10 2014/01/30 12:04:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.12_pre6.ebuild,v 1.11 2014/05/31 04:14:40 axs Exp $
EAPI=4
inherit eutils autotools flag-o-matic
@@ -51,7 +51,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-0.11.2-lua-5.1.patch
fi
- epatch "${FILESDIR}"/${PN}-0.11.5-makefile.patch
+ epatch "${FILESDIR}"/${PN}-9999-parallel-make.patch
epatch "${FILESDIR}"/${PN}-0.12_pre5-compilation-fix.patch
if use javascript ; then
@@ -141,8 +141,12 @@ src_configure() {
${myconf}
}
+src_compile() {
+ emake V=1
+}
+
src_install() {
- emake DESTDIR="${D}" install
+ emake V=1 DESTDIR="${D}" install
insopts -m 644 ; insinto /etc/elinks
doins "${WORKDIR}"/elinks.conf
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
new file mode 100644
index 000000000000..4c0f2c0890db
--- /dev/null
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-9999.ebuild,v 1.1 2014/05/31 04:14:40 axs Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="threads"
+inherit autotools eutils git-r3 flag-o-matic python-any-r1
+
+EGIT_REPO_URI="git://repo.or.cz/elinks.git"
+
+MY_P="${P/_/}"
+DESCRIPTION="Advanced and well-established text-mode web browser"
+HOMEPAGE="http://elinks.or.cz/"
+SRC_URI="http://dev.gentoo.org/~spock/portage/distfiles/elinks-0.10.4.conf.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="bittorrent bzip2 debug finger ftp gopher gpm guile idn ipv6 \
+ javascript lua +mouse nls nntp perl ruby samba ssl unicode X zlib"
+RESTRICT="test"
+
+DEPEND="dev-libs/boehm-gc
+ >=dev-libs/expat-1.95.4
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ X? ( x11-libs/libX11 x11-libs/libXt )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ lua? ( >=dev-lang/lua-5 )
+ gpm? ( >=sys-libs/ncurses-5.2 >=sys-libs/gpm-1.20.0-r5 )
+ guile? ( >=dev-scheme/guile-1.6.4-r1[deprecated,discouraged] )
+ idn? ( net-dns/libidn )
+ perl? ( sys-devel/libperl )
+ ruby? ( dev-lang/ruby dev-ruby/rubygems )
+ samba? ( net-fs/samba )
+ javascript? ( >=dev-lang/spidermonkey-1.8.5:0= )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ mv "${WORKDIR}/${PN}-0.10.4.conf" "${WORKDIR}/${PN}.conf"
+ if ! use ftp ; then
+ sed -i -e 's/\(.*protocol.ftp.*\)/# \1/' "${WORKDIR}"/${PN}.conf
+ fi
+ sed -i -e 's/\(.*set protocol.ftp.use_epsv.*\)/# \1/' "${WORKDIR}"/${PN}.conf
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+
+ epatch_user
+
+ # Regenerate acinclude.m4 - based on autogen.sh.
+ cat > acinclude.m4 <<- _EOF
+ dnl Automatically generated from config/m4/ files.
+ dnl Do not modify!
+ _EOF
+ cat config/m4/*.m4 >> acinclude.m4
+ sed -i -e 's/-Werror//' configure*
+
+ eautoreconf
+}
+
+src_configure() {
+ # NOTE about GNUTSL SSL support (from the README -- 25/12/2002)
+ # As GNUTLS is not yet 100% stable and its support in ELinks is not so well
+ # tested yet, it's recommended for users to give a strong preference to OpenSSL whenever possible.
+ local myconf=""
+
+ if use debug ; then
+ myconf="--enable-debug"
+ else
+ myconf="--enable-fastmem"
+ fi
+
+ if use ssl ; then
+ myconf="${myconf} --with-openssl=${EPREFIX}/usr"
+ else
+ myconf="${myconf} --without-openssl --without-gnutls"
+ fi
+
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/elinks \
+ --enable-leds \
+ --enable-88-colors \
+ --enable-256-colors \
+ --enable-true-color \
+ --enable-html-highlight \
+ $(use_with gpm) \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with X x) \
+ $(use_with lua) \
+ $(use_with guile) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with idn) \
+ $(use_with javascript spidermonkey) \
+ $(use_enable bittorrent) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable ftp) \
+ $(use_enable gopher) \
+ $(use_enable nntp) \
+ $(use_enable finger) \
+ $(use_enable samba smb) \
+ $(use_enable mouse) \
+ ${myconf}
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake V=1 DESTDIR="${D}" install
+
+ insopts -m 644 ; insinto /etc/elinks
+ doins "${WORKDIR}"/elinks.conf
+ newins contrib/keybind-full.conf keybind-full.sample
+ newins contrib/keybind.conf keybind.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES THANKS TODO doc/*.*
+ docinto contrib ; dodoc contrib/{README,colws.diff,elinks[-.]vim*}
+ insinto /usr/share/doc/${PF}/contrib/lua ; doins contrib/lua/{*.lua,elinks-remote}
+ insinto /usr/share/doc/${PF}/contrib/conv ; doins contrib/conv/*.*
+ insinto /usr/share/doc/${PF}/contrib/guile ; doins contrib/guile/*.scm
+
+ # Remove some conflicting files on OSX. The files provided by OSX 10.4
+ # are more or less the same. -- Fabian Groffen (2005-06-30)
+ rm -f "${ED}"/usr/share/locale/locale.alias "${ED}"/usr/lib/charset.alias || die
+}
+
+pkg_postinst() {
+ einfo "This ebuild provides a default config for ELinks."
+ einfo "Please check /etc/elinks/elinks.conf"
+ einfo
+ einfo "You may want to convert your html.cfg and links.cfg of"
+ einfo "Links or older ELinks versions to the new ELinks elinks.conf"
+ einfo "using /usr/share/doc/${PF}/contrib/conv/conf-links2elinks.pl"
+ einfo
+ einfo "Please have a look at /etc/elinks/keybind-full.sample and"
+ einfo "/etc/elinks/keybind.conf.sample for some bindings examples."
+ einfo
+ einfo "You will have to set your TERM variable to 'xterm-256color'"
+ einfo "to be able to use 256 colors in elinks."
+ echo
+}
diff --git a/www-client/elinks/files/elinks-9999-parallel-make.patch b/www-client/elinks/files/elinks-9999-parallel-make.patch
new file mode 100644
index 000000000000..86aea5588a2f
--- /dev/null
+++ b/www-client/elinks/files/elinks-9999-parallel-make.patch
@@ -0,0 +1,51 @@
+--- a/Makefile.lib 2014-05-30 13:45:11.756422117 -0400
++++ b/Makefile.lib 2014-05-30 13:47:22.626423230 -0400
+@@ -117,7 +117,7 @@
+ $(sort $(filter-out $(LIB_O_NAME),$(OBJS))) \
+ $(foreach subdir,$(sort $(SUBDIRS)),$(wildcard $(subdir)/$(LIB_O_NAME)))
+
+-$(LIB_O_NAME): $(LIB_O_DEPS)
++$(LIB_O_NAME): all-recursive.built $(LIB_O_DEPS)
+ $(call cmd,ld_objs)
+
+ DEP_FILES_1 = $(foreach src,$(OBJS),.deps/$(src))
+@@ -260,21 +260,36 @@
+ # remaining subdirectories, but return an error at the end.
+ $(RULES_REC):
+ ifneq (,$(findstring k,$(MAKEFLAGS)))
+- @suberr=0; \
++ @+suberr=0; \
+ $(foreach subdir,$(sort $(SUBDIRS)), \
+ $(call ncmd,recmake,$(subdir),$(subst -recursive,,$@)) || suberr=1;) \
+ exit $$suberr
+ else
+- @$(foreach subdir,$(sort $(SUBDIRS)), \
++ @+$(foreach subdir,$(sort $(SUBDIRS)), \
+ $(call ncmd,recmake,$(subdir),$(subst -recursive,,$@)) || exit 1;)
+ endif
+
++all-recursive.built:
++ifneq (,$(findstring k,$(MAKEFLAGS)))
++ @+suberr=0; \
++ $(foreach subdir,$(sort $(SUBDIRS)), \
++ $(call ncmd,recmake,$(subdir),$(subst -recursive.built,,$@)) || suberr=1;) \
++ [ $$suberr == 0 ] && touch $@; \
++ exit $$suberr
++else
++ @+$(foreach subdir,$(sort $(SUBDIRS)), \
++ $(call ncmd,recmake,$(subdir),$(subst -recursive.built,,$@)) || exit 1;) \
++ touch $@
++endif
++
++CLEAN += all-recursive.built
++
+ # Dummy -local rules
+ $(RULES_LOCAL):
+
+ # Default deps
+ rule_deps = $(1)-recursive $(1)-default $(1)-local
+-all: $(call rule_deps,all)
++all: $(subst recursive,recursive.built,$(call rule_deps,all))
+ install: $(call rule_deps,install)
+ clean: $(call rule_deps,clean)
+ cleanall: $(call rule_deps,cleanall)