summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-11 09:31:59 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-11 09:31:59 +0000
commit168b7c4d3ffc01fcd85cd92873e431fdb0f27a5e (patch)
tree17484dc9b5f2ff7e22fa2ee7ab6742ed7c327eac /www-client
parentVersion bump. (diff)
downloadgentoo-2-168b7c4d3ffc01fcd85cd92873e431fdb0f27a5e.tar.gz
gentoo-2-168b7c4d3ffc01fcd85cd92873e431fdb0f27a5e.tar.bz2
gentoo-2-168b7c4d3ffc01fcd85cd92873e431fdb0f27a5e.zip
Fix building in non-C locales #131440 by Andres Toomsalu.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/links/ChangeLog8
-rw-r--r--www-client/links/files/configure-LANG.patch64
-rw-r--r--www-client/links/links-2.1_pre23.ebuild12
3 files changed, 76 insertions, 8 deletions
diff --git a/www-client/links/ChangeLog b/www-client/links/ChangeLog
index c4c8e09f0313..234ff8a54652 100644
--- a/www-client/links/ChangeLog
+++ b/www-client/links/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/links
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.72 2006/10/15 16:53:18 vanquirius Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/ChangeLog,v 1.73 2006/11/11 09:31:59 vapier Exp $
+
+ 11 Nov 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/configure-LANG.patch, links-2.1_pre23.ebuild:
+ Fix building in non-C locales #131440 by Andres Toomsalu.
*links-2.1_pre23 (15 Oct 2006)
diff --git a/www-client/links/files/configure-LANG.patch b/www-client/links/files/configure-LANG.patch
new file mode 100644
index 000000000000..d1b1b0353662
--- /dev/null
+++ b/www-client/links/files/configure-LANG.patch
@@ -0,0 +1,64 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+
+--- configure
++++ configure
+@@ -54,6 +54,19 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval $as_var=C; export $as_var) 2>&1`"); then
++ eval $as_var=C; export $as_var
++ else
++ unset $as_var
++ fi
++done
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
+@@ -1850,6 +1850,19 @@
+ # Compiler output produced by configure, useful for debugging
+ # configure, is in ./config.log if it exists.
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval \$as_var=C; export \$as_var) 2>&1`"); then
++ eval \$as_var=C; export \$as_var
++ else
++ unset \$as_var
++ fi
++done
++
+ ac_cs_usage="Usage: $CONFIG_STATUS [--recheck] [--version] [--help]"
+ for ac_option
+ do
diff --git a/www-client/links/links-2.1_pre23.ebuild b/www-client/links/links-2.1_pre23.ebuild
index 68240c756581..3c21048ce557 100644
--- a/www-client/links/links-2.1_pre23.ebuild
+++ b/www-client/links/links-2.1_pre23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.1_pre23.ebuild,v 1.1 2006/10/15 16:53:19 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/links/links-2.1_pre23.ebuild,v 1.2 2006/11/11 09:31:59 vapier Exp $
inherit eutils toolchain-funcs
@@ -52,9 +52,10 @@ DEPEND="${RDEPEND}
src_unpack (){
unpack ${A}; cd "${S}"
+ epatch "${FILESDIR}"/configure-LANG.patch #131440
+
if use unicode ; then
epatch "${WORKDIR}/${PN}-2.1pre22-utf8.diff"
- export LANG=C
cd "${S}/intl" && ./gen-intl && cd .. || die "gen-intl filed"
fi
}
@@ -102,8 +103,8 @@ src_compile (){
emake || die "make failed"
}
-src_install (){
- einstall
+src_install() {
+ einstall || die
# Only install links icon if X driver was compiled in ...
use X && doicon graphics/links.xpm
@@ -117,8 +118,7 @@ src_install (){
pkg_postinst() {
- if use svga
- then
+ if use svga ; then
einfo "You had the svga USE flag enabled, but for security reasons"
einfo "the links2 binary is NOT setuid by default. In order to"
einfo "enable links2 to work in SVGA, please change the permissions"