summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-30 22:19:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-04-30 22:19:54 +0000
commit08ca63a1c4a2beb61a0ef1c1236584d5e9b0388c (patch)
tree9405ddaf7005552c6603e552316229a3031fe571 /www-client
parentRemove old version (diff)
downloadgentoo-2-08ca63a1c4a2beb61a0ef1c1236584d5e9b0388c.tar.gz
gentoo-2-08ca63a1c4a2beb61a0ef1c1236584d5e9b0388c.tar.bz2
gentoo-2-08ca63a1c4a2beb61a0ef1c1236584d5e9b0388c.zip
Add a patch to fix building lynx in parallel. Closes bug #403905.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/lynx/ChangeLog6
-rw-r--r--www-client/lynx/files/lynx-2.8.8_pre12-parallel.patch146
-rw-r--r--www-client/lynx/lynx-2.8.8_pre12.ebuild18
3 files changed, 157 insertions, 13 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index 5b7a1234ea19..dd8fa92b2a2a 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/lynx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.116 2012/04/27 05:12:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.117 2012/04/30 22:19:54 flameeyes Exp $
+
+ 30 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/lynx-2.8.8_pre12-parallel.patch, lynx-2.8.8_pre12.ebuild:
+ Add a patch to fix building lynx in parallel. Closes bug #403905.
27 Apr 2012; Diego E. Pettenò <flameeyes@gentoo.org> lynx-2.8.7_p1.ebuild:
Use -j1 for the current stable as well.
diff --git a/www-client/lynx/files/lynx-2.8.8_pre12-parallel.patch b/www-client/lynx/files/lynx-2.8.8_pre12-parallel.patch
new file mode 100644
index 000000000000..5eb30b641ef8
--- /dev/null
+++ b/www-client/lynx/files/lynx-2.8.8_pre12-parallel.patch
@@ -0,0 +1,146 @@
+Index: lynx2-8-8/src/makefile.in
+===================================================================
+--- lynx2-8-8.orig/src/makefile.in
++++ lynx2-8-8/src/makefile.in
+@@ -100,7 +100,7 @@ all: lynx$x
+ @RULE_CC@
+ @ECHO_CC@$(CPP) -C $(CPP_OPTS) $< >$@
+
+-lynx$x: message do_chartrans_stuff $(top_builddir)/LYHelp.h $(OBJS) $(WWWLIB)
++lynx$x: message $(top_builddir)/LYHelp.h $(OBJS) $(WWWLIB)
+ @echo "Linking and creating Lynx executable"
+ $(CC) $(CC_OPTS) $(LDFLAGS) -o $@ $(OBJS) $(WWWLIB) $(LDFLAGS) $(LIBS) $(INTLLIB)
+ @echo "Copying Lynx executable into top-level directory"
+@@ -111,21 +111,12 @@ lynx$x: message do_chartrans_stuff $(t
+ message:
+ @echo "Compiling Lynx sources"
+
+-do_chartrans_stuff:
+- -cd chrtrans && $(MAKE) \
+- SITE_DEFS="$(SITE_DEFS)" \
+- BUILD_CFLAGS="$(BUILD_CFLAGS)" \
+- BUILD_CPPFLAGS="$(BUILD_CPPFLAGS)" \
+- BUILD_LDFLAGS="$(BUILD_LDFLAGS)" \
+- BUILD_LIBS="$(BUILD_LIBS)" \
+- BUILD_CC="$(BUILD_CC)" tables
+-
+ lint:
+ $(LINT) $(LINTOPTS) $(CPP_OPTS) $(C_SRC) 2>&1 |tee $(top_builddir)/lint.lynx
+
+ clean:
+ rm -f lynx$x core *.core *.leaks *.i *$o *.bak tags TAGS test_*
+- cd chrtrans && $(MAKE) clean
++ $(MAKE) -C chrtrans clean
+
+ tags:
+ $(CTAGS) *.[ch]
+@@ -169,9 +160,11 @@ TABLES= \
+ $(CHRTR)cp775_uni.h \
+ $(CHRTR)cp850_uni.h \
+ $(CHRTR)cp852_uni.h \
++ $(CHRTR)cp857_uni.h \
+ $(CHRTR)cp862_uni.h \
+ $(CHRTR)cp864_uni.h \
+ $(CHRTR)cp866_uni.h \
++ $(CHRTR)cp866u_uni.h \
+ $(CHRTR)cp869_uni.h \
+ $(CHRTR)def7_uni.h \
+ $(CHRTR)dmcs_uni.h \
+@@ -186,27 +179,29 @@ TABLES= \
+ $(CHRTR)iso08_uni.h \
+ $(CHRTR)iso09_uni.h \
+ $(CHRTR)iso10_uni.h \
++ $(CHRTR)iso13_uni.h \
++ $(CHRTR)iso14_uni.h \
+ $(CHRTR)iso15_uni.h \
+ $(CHRTR)koi8r_uni.h \
++ $(CHRTR)koi8u_uni.h \
+ $(CHRTR)mac_uni.h \
+ $(CHRTR)mnem_suni.h \
+ $(CHRTR)mnem2_suni.h \
+ $(CHRTR)next_uni.h \
++ $(CHRTR)pt154_uni.h \
+ $(CHRTR)rfc_suni.h \
+ $(CHRTR)utf8_uni.h \
+ $(CHRTR)viscii_uni.h
+
+-$(TABLES):
+- -cd chrtrans && $(MAKE) tables
++$(TABLES): chrtrans/makeuctb$(BUILD_EXEEXT)
++ $(MAKE) -C chrtrans `basename $@`
+
+ UCdomap$o : UCdomap.c \
+ chrtrans/UCkd.h \
+- chrtrans/makeuctb$(BUILD_EXEEXT) \
+- chrtrans/makeuctb.c \
+- UCdomap.h $(CMN)UCMap.h $(TABLES) $(top_srcdir)/userdefs.h
++ UCdomap.h $(CMN)UCMap.h $(TABLES) $(top_srcdir)/userdefs.h
+
+ chrtrans/makeuctb$(BUILD_EXEEXT):
+- cd chrtrans; make makeuctb$(BUILD_EXEEXT)
++ $(MAKE) -C chrtrans makeuctb$(BUILD_EXEEXT)
+
+ UCAux$o : UCAux.c $(CMN)UCAux.h $(CMN)UCDefs.h
+ LYCookie$o : $(top_srcdir)/userdefs.h
+Index: lynx2-8-8/src/chrtrans/makefile.in
+===================================================================
+--- lynx2-8-8.orig/src/chrtrans/makefile.in
++++ lynx2-8-8/src/chrtrans/makefile.in
+@@ -67,57 +67,8 @@ FONTMAP_INC = iso01_uni.h# default, if n
+
+ MAKEUCTB = makeuctb$(BUILD_EXEEXT)
+
+-TABLES= \
+- cp1250_uni.h \
+- cp1251_uni.h \
+- cp1252_uni.h \
+- cp1253_uni.h \
+- cp1255_uni.h \
+- cp1256_uni.h \
+- cp1257_uni.h \
+- cp437_uni.h \
+- cp737_uni.h \
+- cp775_uni.h \
+- cp850_uni.h \
+- cp852_uni.h \
+- cp857_uni.h \
+- cp862_uni.h \
+- cp864_uni.h \
+- cp866_uni.h \
+- cp866u_uni.h \
+- cp869_uni.h \
+- def7_uni.h \
+- dmcs_uni.h \
+- hp_uni.h \
+- iso01_uni.h \
+- iso02_uni.h \
+- iso03_uni.h \
+- iso04_uni.h \
+- iso05_uni.h \
+- iso06_uni.h \
+- iso07_uni.h \
+- iso08_uni.h \
+- iso09_uni.h \
+- iso10_uni.h \
+- iso13_uni.h \
+- iso14_uni.h \
+- iso15_uni.h \
+- koi8r_uni.h \
+- koi8u_uni.h \
+- mac_uni.h \
+- mnem2_suni.h \
+- mnem_suni.h \
+- next_uni.h \
+- next_uni.h \
+- pt154_uni.h \
+- rfc_suni.h \
+- utf8_uni.h \
+- viscii_uni.h
+-
+ default: $(FONTMAP_INC)
+
+-tables: $(TABLES)
+-
+ OBJS = makeuctb$o
+ C_SRC = $(OBJS:$o=.c)
+
diff --git a/www-client/lynx/lynx-2.8.8_pre12.ebuild b/www-client/lynx/lynx-2.8.8_pre12.ebuild
index b5d931d80cd1..f7def3049f8f 100644
--- a/www-client/lynx/lynx-2.8.8_pre12.ebuild
+++ b/www-client/lynx/lynx-2.8.8_pre12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.8_pre12.ebuild,v 1.2 2012/04/26 04:49:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.8_pre12.ebuild,v 1.3 2012/04/30 22:19:54 flameeyes Exp $
EAPI=4
@@ -48,16 +48,10 @@ pkg_setup() {
}
src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
- die "failed to update makefile.in"
-
# fix configure for openssl compiled with kerberos (bug #267749)
epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
epatch "${FILESDIR}"/${PN}-2.8.6-mint.patch
+ epatch "${FILESDIR}"/lynx-2.8.8_pre12-parallel.patch
}
src_configure() {
@@ -98,10 +92,10 @@ src_configure() {
$myargs
}
-src_compile() {
- # see bug #403905
- emake -j1
-}
+#src_compile() {
+# # see bug #403905
+# emake -j1
+#}
src_install() {
emake install DESTDIR="${D}"