summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-09-12 15:01:44 +0000
committerJeroen Roovers <jer@gentoo.org>2013-09-12 15:01:44 +0000
commit281c2d8b3eb669205d6275cf8d36b0f94a44ead0 (patch)
tree81a4b5b3dbbbaca6017e41b378e09a188d19f433 /www-client/surf
parentStable for HPPA (bug #461372). (diff)
downloadgentoo-2-281c2d8b3eb669205d6275cf8d36b0f94a44ead0.tar.gz
gentoo-2-281c2d8b3eb669205d6275cf8d36b0f94a44ead0.tar.bz2
gentoo-2-281c2d8b3eb669205d6275cf8d36b0f94a44ead0.zip
Add epatch_user, remove xterm dependency (bug #481700 by Ari Malinen).
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/ChangeLog7
-rw-r--r--www-client/surf/surf-0.6-r1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/www-client/surf/ChangeLog b/www-client/surf/ChangeLog
index b671bd78aa94..b71c1a90c1e7 100644
--- a/www-client/surf/ChangeLog
+++ b/www-client/surf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/surf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.27 2013/04/08 11:57:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.28 2013/09/12 15:01:44 jer Exp $
+
+*surf-0.6-r1 (12 Sep 2013)
+
+ 12 Sep 2013; Jeroen Roovers <jer@gentoo.org> +surf-0.6-r1.ebuild:
+ Add epatch_user, remove xterm dependency (bug #481700 by Ari Malinen).
08 Apr 2013; Jeroen Roovers <jer@gentoo.org> -surf-0.5.ebuild:
Old.
diff --git a/www-client/surf/surf-0.6-r1.ebuild b/www-client/surf/surf-0.6-r1.ebuild
new file mode 100644
index 000000000000..4149f450904e
--- /dev/null
+++ b/www-client/surf/surf-0.6-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-0.6-r1.ebuild,v 1.1 2013/09/12 15:01:44 jer Exp $
+
+EAPI=5
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+RDEPEND="
+ !sci-chemistry/surf
+ !savedconfig? ( net-misc/wget )
+ x11-apps/xprop
+ x11-misc/dmenu
+ ${DEPEND}
+"
+
+pkg_setup() {
+ elog "net-misc/wget will be installed by default to"
+ elog "support the default download command, which can be changed through"
+ elog "the savedconfig mechanism. If you enable USE=savedconfig, you will"
+ elog "need to satisfy requirements for the alternative download command"
+ elog "yourself."
+}
+
+src_prepare() {
+ epatch_user
+ sed -i \
+ -e 's|{|(|g;s|}|)|g' \
+ -e 's|\t@|\t|g;s|echo|@&|g' \
+ -e 's|^LIBS.*|LIBS = $(GTKLIB) -lgthread-2.0|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
+ -e 's|^CC.*|CC ?= gcc|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ config.mk Makefile || die
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ save_config config.h
+}
+
+pkg_postinst() {
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+}