summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-07-04 18:45:08 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-07-04 18:45:08 +0000
commitc70e0a88126ff0ed8032de62e9bacfd3f3a66a4c (patch)
tree8d1816038a6fbefb63a6cf6f7e560b59fe0ceffd /www-client/elinks
parentfix DEPENDS properly and add app-arch/unzip (diff)
downloadgentoo-2-c70e0a88126ff0ed8032de62e9bacfd3f3a66a4c.tar.gz
gentoo-2-c70e0a88126ff0ed8032de62e9bacfd3f3a66a4c.tar.bz2
gentoo-2-c70e0a88126ff0ed8032de62e9bacfd3f3a66a4c.zip
fixed configure check for ruby-1.9 and above, bug 424789
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'www-client/elinks')
-rw-r--r--www-client/elinks/ChangeLog6
-rw-r--r--www-client/elinks/elinks-0.12_pre5-r2.ebuild3
-rw-r--r--www-client/elinks/files/elinks-0.12_pre5-ruby-config.patch11
3 files changed, 18 insertions, 2 deletions
diff --git a/www-client/elinks/ChangeLog b/www-client/elinks/ChangeLog
index 9c486ffb0777..0367f1052652 100644
--- a/www-client/elinks/ChangeLog
+++ b/www-client/elinks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/elinks
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/ChangeLog,v 1.143 2012/06/28 17:05:31 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/ChangeLog,v 1.144 2012/07/04 18:45:08 axs Exp $
+
+ 04 Jul 2012; Ian Stakenvicius <axs@gentoo.org> elinks-0.12_pre5-r2.ebuild,
+ +files/elinks-0.12_pre5-ruby-config.patch:
+ fixed configure check for ruby-1.9 and above, bug 424789
28 Jun 2012; Ian Stakenvicius <axs@gentoo.org> elinks-0.12_pre5-r2.ebuild,
+files/elinks-0.12_pre5-sm185-jsval-fixes.patch:
diff --git a/www-client/elinks/elinks-0.12_pre5-r2.ebuild b/www-client/elinks/elinks-0.12_pre5-r2.ebuild
index 4045468dcf11..fcb793d1f4bf 100644
--- a/www-client/elinks/elinks-0.12_pre5-r2.ebuild
+++ b/www-client/elinks/elinks-0.12_pre5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.12_pre5-r2.ebuild,v 1.2 2012/06/28 17:05:31 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/elinks/elinks-0.12_pre5-r2.ebuild,v 1.3 2012/07/04 18:45:08 axs Exp $
EAPI=4
inherit eutils autotools flag-o-matic
@@ -68,6 +68,7 @@ src_prepare() {
epatch "${FILESDIR}"/${MY_P}-spidermonkey-callback.patch
fi
fi
+ epatch "${FILESDIR}"/${P}-ruby-config.patch
sed -i -e 's/-Werror//' configure*
eautoreconf
diff --git a/www-client/elinks/files/elinks-0.12_pre5-ruby-config.patch b/www-client/elinks/files/elinks-0.12_pre5-ruby-config.patch
new file mode 100644
index 000000000000..83117e8ed450
--- /dev/null
+++ b/www-client/elinks/files/elinks-0.12_pre5-ruby-config.patch
@@ -0,0 +1,11 @@
+--- a/config/m4/ruby.m4 2009-07-07 08:23:17.000000000 -0400
++++ b/config/m4/ruby.m4 2012-07-04 14:37:13.000000000 -0400
+@@ -32,7 +32,7 @@
+ if test "$CONFIG_SCRIPTING_RUBY" != "no"; then
+
+ AC_MSG_CHECKING(Ruby version)
+- if $CONFIG_SCRIPTING_RUBY -e 'exit((VERSION or RUBY_VERSION) >= "1.6.0")' >/dev/null 2>/dev/null; then
++ if $CONFIG_SCRIPTING_RUBY -e 'exit((RUBY_VERSION or VERSION) >= "1.6.0")' >/dev/null 2>/dev/null; then
+ ruby_version=`$CONFIG_SCRIPTING_RUBY -e 'puts "#{VERSION rescue RUBY_VERSION}"'`
+ AC_MSG_RESULT($ruby_version)
+