summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-12-19 06:07:02 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-12-19 06:07:02 +0000
commit3325602b4e7cd57f9d287c3eebb7b1b007d19914 (patch)
treef3bbab50791e28b2afc0364d2cee909d162aaa97 /www-apps
parentRefactoring: Inline gcc-compiler-configure() into gcc_do_configure(). Clean (diff)
downloadgentoo-2-3325602b4e7cd57f9d287c3eebb7b1b007d19914.tar.gz
gentoo-2-3325602b4e7cd57f9d287c3eebb7b1b007d19914.tar.bz2
gentoo-2-3325602b4e7cd57f9d287c3eebb7b1b007d19914.zip
now using 2013.2.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/horizon/ChangeLog9
-rw-r--r--www-apps/horizon/files/cve-2013-6858_2013.2.patch77
-rw-r--r--www-apps/horizon/horizon-2013.2.1.ebuild (renamed from www-apps/horizon/horizon-2013.2-r2.ebuild)12
-rw-r--r--www-apps/horizon/horizon-2013.2.9999.ebuild12
4 files changed, 21 insertions, 89 deletions
diff --git a/www-apps/horizon/ChangeLog b/www-apps/horizon/ChangeLog
index dd1e70f4c597..507099fff1d1 100644
--- a/www-apps/horizon/ChangeLog
+++ b/www-apps/horizon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/horizon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/ChangeLog,v 1.18 2013/12/13 17:14:33 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/ChangeLog,v 1.19 2013/12/19 06:07:02 prometheanfire Exp $
+
+*horizon-2013.2.1 (19 Dec 2013)
+
+ 19 Dec 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +horizon-2013.2.1.ebuild, -files/cve-2013-6858_2013.2.patch,
+ -horizon-2013.2-r2.ebuild, horizon-2013.2.9999.ebuild:
+ now using 2013.2.1
13 Dec 2013; Matthew Thode <prometheanfire@gentoo.org>
-horizon-2013.2-r1.ebuild:
diff --git a/www-apps/horizon/files/cve-2013-6858_2013.2.patch b/www-apps/horizon/files/cve-2013-6858_2013.2.patch
deleted file mode 100644
index 885aecbd190b..000000000000
--- a/www-apps/horizon/files/cve-2013-6858_2013.2.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 6179f70290783e55b10bbd4b3b7ee74db3f8ef70 Mon Sep 17 00:00:00 2001
-From: Rob Raymond <rob.raymond@hp.com>
-Date: Mon, 4 Nov 2013 12:12:40 -0700
-Subject: [PATCH] Fix bug by escaping strings from Nova before displaying them
-
-Fixes bug #1247675
-
-(cherry-picked from commit b8ff480)
-Change-Id: I3637faafec1e1fba081533ee020f4ee218fea101
----
- .../project/images_and_snapshots/volume_snapshots/tables.py | 2 ++
- openstack_dashboard/dashboards/project/volumes/tables.py | 8 ++++----
- 2 files changed, 6 insertions(+), 4 deletions(-)
-
-diff --git a/openstack_dashboard/dashboards/project/images_and_snapshots/volume_snapshots/tables.py b/openstack_dashboard/dashboards/project/images_and_snapshots/volume_snapshots/tables.py
-index 17008f5..e5a3c69 100644
---- a/openstack_dashboard/dashboards/project/images_and_snapshots/volume_snapshots/tables.py
-+++ b/openstack_dashboard/dashboards/project/images_and_snapshots/volume_snapshots/tables.py
-@@ -15,6 +15,7 @@
- # under the License.
-
- from django.core.urlresolvers import reverse # noqa
-+from django.utils import html
- from django.utils.http import urlencode # noqa
- from django.utils import safestring
- from django.utils.translation import ugettext_lazy as _ # noqa
-@@ -66,6 +67,7 @@ def get_raw_data(self, snapshot):
- volume = snapshot._volume
- if volume:
- volume_name = volume.display_name or volume.id
-+ volume_name = html.escape(volume_name)
- else:
- volume_name = _("Unknown")
- return safestring.mark_safe(volume_name)
-diff --git a/openstack_dashboard/dashboards/project/volumes/tables.py b/openstack_dashboard/dashboards/project/volumes/tables.py
-index c84bf00..f993f18 100644
---- a/openstack_dashboard/dashboards/project/volumes/tables.py
-+++ b/openstack_dashboard/dashboards/project/volumes/tables.py
-@@ -17,7 +17,7 @@
- from django.core.urlresolvers import NoReverseMatch # noqa
- from django.core.urlresolvers import reverse # noqa
- from django.template.defaultfilters import title # noqa
--from django.utils.html import strip_tags # noqa
-+from django.utils import html
- from django.utils import safestring
- from django.utils.translation import string_concat # noqa
- from django.utils.translation import ugettext_lazy as _ # noqa
-@@ -125,7 +125,7 @@ def get_attachment_name(request, attachment):
- "attachment information."))
- try:
- url = reverse("horizon:project:instances:detail", args=(server_id,))
-- instance = '<a href="%s">%s</a>' % (url, name)
-+ instance = '<a href="%s">%s</a>' % (url, html.escape(name))
- except NoReverseMatch:
- instance = name
- return instance
-@@ -146,7 +146,7 @@ def get_raw_data(self, volume):
- # without the server name...
- instance = get_attachment_name(request, attachment)
- vals = {"instance": instance,
-- "dev": attachment["device"]}
-+ "dev": html.escape(attachment["device"])}
- attachments.append(link % vals)
- return safestring.mark_safe(", ".join(attachments))
-
-@@ -249,7 +249,7 @@ def get_object_id(self, obj):
- def get_object_display(self, attachment):
- instance_name = get_attachment_name(self.request, attachment)
- vals = {"dev": attachment['device'],
-- "instance_name": strip_tags(instance_name)}
-+ "instance_name": html.escape(instance_name)}
- return _("%(dev)s on instance %(instance_name)s") % vals
-
- def get_object_by_id(self, obj_id):
---
-1.8.5.1
-
diff --git a/www-apps/horizon/horizon-2013.2-r2.ebuild b/www-apps/horizon/horizon-2013.2.1.ebuild
index e0825600f358..82e0dbfcee75 100644
--- a/www-apps/horizon/horizon-2013.2-r2.ebuild
+++ b/www-apps/horizon/horizon-2013.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.2-r2.ebuild,v 1.1 2013/12/13 17:13:20 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.2.1.ebuild,v 1.1 2013/12/19 06:07:02 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -31,19 +31,20 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/nosehtmloutput-0.0.3[${PYTHON_USEDEP}]
dev-python/selenium[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
=dev-python/docutils-0.9.1-r1[${PYTHON_USEDEP}]
dev-python/oslo-sphinx[${PYTHON_USEDEP}]
)"
RDEPEND=">=dev-python/django-1.4[${PYTHON_USEDEP}]
<dev-python/django-1.6[${PYTHON_USEDEP}]
>=dev-python/django-compressor-1.3[${PYTHON_USEDEP}]
- >=dev-python/django-openstack-auth-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/django-openstack-auth-1.1.3[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
>=dev-python/kombu-2.4.8[${PYTHON_USEDEP}]
>=dev-python/lesscpy-0.9j[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.8[${PYTHON_USEDEP}]
dev-python/netaddr[${PYTHON_USEDEP}]
- >=dev-python/python-cinderclient-1.0.5[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.0.6[${PYTHON_USEDEP}]
>=dev-python/python-glanceclient-0.9.0[${PYTHON_USEDEP}]
>=dev-python/python-heatclient-0.2.3[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]
@@ -56,7 +57,8 @@ RDEPEND=">=dev-python/django-1.4[${PYTHON_USEDEP}]
>=dev-python/pytz-2010h[${PYTHON_USEDEP}]
>=dev-python/lockfile-0.8[${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}/cve-2013-6858_2013.2.patch" )
+PATCHES=(
+)
src_test() {
./run_tests.sh -N --coverage
diff --git a/www-apps/horizon/horizon-2013.2.9999.ebuild b/www-apps/horizon/horizon-2013.2.9999.ebuild
index fc0c6cfd2b14..e347abd004b9 100644
--- a/www-apps/horizon/horizon-2013.2.9999.ebuild
+++ b/www-apps/horizon/horizon-2013.2.9999.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.2.9999.ebuild,v 1.2 2013/11/27 04:37:26 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horizon/horizon-2013.2.9999.ebuild,v 1.3 2013/12/19 06:07:02 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 git-2
-DESCRIPTION="Horizon is a Django-based project aimed at providing a complete
-OpenStack Dashboard."
+DESCRIPTION="A Django-based project aimed at providing a complete OpenStack Dashboard."
HOMEPAGE="https://launchpad.net/horizon"
EGIT_REPO_URI="https://github.com/openstack/horizon.git"
EGIT_BRANCH="stable/havana"
@@ -33,19 +32,20 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/nosehtmloutput-0.0.3[${PYTHON_USEDEP}]
dev-python/selenium[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
=dev-python/docutils-0.9.1-r1[${PYTHON_USEDEP}]
dev-python/oslo-sphinx[${PYTHON_USEDEP}]
)"
RDEPEND=">=dev-python/django-1.4[${PYTHON_USEDEP}]
<dev-python/django-1.6[${PYTHON_USEDEP}]
>=dev-python/django-compressor-1.3[${PYTHON_USEDEP}]
- >=dev-python/django-openstack-auth-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/django-openstack-auth-1.1.3[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
>=dev-python/kombu-2.4.8[${PYTHON_USEDEP}]
>=dev-python/lesscpy-0.9j[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.8[${PYTHON_USEDEP}]
dev-python/netaddr[${PYTHON_USEDEP}]
- >=dev-python/python-cinderclient-1.0.5[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.0.6[${PYTHON_USEDEP}]
>=dev-python/python-glanceclient-0.9.0[${PYTHON_USEDEP}]
>=dev-python/python-heatclient-0.2.3[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]