summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-10 03:00:19 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-10 03:00:19 +0000
commit286ec9ba63ef99e2e534d35e453eff2657c95e61 (patch)
tree2a43d9213e6a6860c1d4615ce00e520b663e9e8b /www-apps
parentVersion bump. (diff)
downloadgentoo-2-286ec9ba63ef99e2e534d35e453eff2657c95e61.tar.gz
gentoo-2-286ec9ba63ef99e2e534d35e453eff2657c95e61.tar.bz2
gentoo-2-286ec9ba63ef99e2e534d35e453eff2657c95e61.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpsysinfo/ChangeLog9
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.1.17.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/www-apps/phpsysinfo/ChangeLog b/www-apps/phpsysinfo/ChangeLog
index 2c37704e5484..5b4c543f5918 100644
--- a/www-apps/phpsysinfo/ChangeLog
+++ b/www-apps/phpsysinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/phpsysinfo
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/ChangeLog,v 1.87 2014/08/10 20:14:37 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/ChangeLog,v 1.88 2015/01/10 03:00:19 radhermit Exp $
+
+*phpsysinfo-3.1.17 (10 Jan 2015)
+
+ 10 Jan 2015; Tim Harder <radhermit@gentoo.org> +phpsysinfo-3.1.17.ebuild:
+ Version bump.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> phpsysinfo-3.0.19.ebuild,
phpsysinfo-3.0.20.ebuild:
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.1.17.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.1.17.ebuild
new file mode 100644
index 000000000000..920ed8e4afb5
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.1.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/phpsysinfo-3.1.17.ebuild,v 1.1 2015/01/10 03:00:19 radhermit Exp $
+
+EAPI=5
+
+inherit webapp
+
+DESCRIPTION="phpSysInfo is a nice package that will display your system stats via PHP"
+HOMEPAGE="http://rk4an.github.com/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+RDEPEND="virtual/httpd-php
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore .travis.yml || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ newins phpsysinfo.ini{.new,}
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+ webapp_src_install
+}