summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-08-26 17:15:20 +0000
committerBen de Groot <yngwin@gentoo.org>2012-08-26 17:15:20 +0000
commit7b77cf4323807c99582f27baf9189d9864425a6c (patch)
tree7929de24e106dfa16ed7bb9b784c3f233ddf6788 /www-apps/nikola/nikola-4.0.1.ebuild
parentLinux patch 3.5.3 (diff)
downloadgentoo-2-7b77cf4323807c99582f27baf9189d9864425a6c.tar.gz
gentoo-2-7b77cf4323807c99582f27baf9189d9864425a6c.tar.bz2
gentoo-2-7b77cf4323807c99582f27baf9189d9864425a6c.zip
Version bump
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/nikola/nikola-4.0.1.ebuild')
-rw-r--r--www-apps/nikola/nikola-4.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/nikola/nikola-4.0.1.ebuild b/www-apps/nikola/nikola-4.0.1.ebuild
new file mode 100644
index 000000000000..4e6b8c99c8ac
--- /dev/null
+++ b/www-apps/nikola/nikola-4.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-4.0.1.ebuild,v 1.1 2012/08/26 17:15:20 yngwin Exp $
+
+EAPI=4
+PYTHON_COMPAT="python2_6 python2_7"
+
+inherit python-distutils-ng
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="http://nikola.ralsina.com.ar/"
+SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/docutils
+ dev-python/doit
+ dev-python/imaging
+ >=dev-python/mako-0.6
+ dev-python/pygments"
+
+src_install() {
+ python-distutils-ng_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm "${D}"/usr/*.txt
+
+ dodoc README.md docs/*
+}