summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-03-10 15:04:58 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-03-10 15:04:58 +0000
commit62e2cfea66243f87f9be735d088833cc5cc6b971 (patch)
tree0f2b0fc3b3308b7c197d7695f265a15ce17682d4 /www-apps/moodle
parentVersion bump (diff)
downloadgentoo-2-62e2cfea66243f87f9be735d088833cc5cc6b971.tar.gz
gentoo-2-62e2cfea66243f87f9be735d088833cc5cc6b971.tar.bz2
gentoo-2-62e2cfea66243f87f9be735d088833cc5cc6b971.zip
Removed decprecated versions, bug #353431
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/moodle')
-rw-r--r--www-apps/moodle/ChangeLog6
-rw-r--r--www-apps/moodle/moodle-1.9.10.ebuild121
-rw-r--r--www-apps/moodle/moodle-1.9.9-r1.ebuild121
-rw-r--r--www-apps/moodle/moodle-1.9.9.ebuild121
-rw-r--r--www-apps/moodle/moodle-2.0.1.ebuild133
5 files changed, 5 insertions, 497 deletions
diff --git a/www-apps/moodle/ChangeLog b/www-apps/moodle/ChangeLog
index de0c91e1a19c..5414792ae31d 100644
--- a/www-apps/moodle/ChangeLog
+++ b/www-apps/moodle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/moodle
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.5 2011/02/22 16:22:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/ChangeLog,v 1.6 2011/03/10 15:04:58 blueness Exp $
+
+ 10 Mar 2011; Anthony G. Basile <blueness@gentoo.org> -moodle-1.9.9.ebuild,
+ -moodle-1.9.9-r1.ebuild, -moodle-1.9.10.ebuild, -moodle-2.0.1.ebuild:
+ Removed decprecated versions, bug #353431
*moodle-2.0.2 (22 Feb 2011)
*moodle-1.9.11 (22 Feb 2011)
diff --git a/www-apps/moodle/moodle-1.9.10.ebuild b/www-apps/moodle/moodle-1.9.10.ebuild
deleted file mode 100644
index bbb011632d8d..000000000000
--- a/www-apps/moodle/moodle-1.9.10.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-1.9.10.ebuild,v 1.1 2010/10/29 15:55:40 blueness Exp $
-
-EAPI="2"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DBFLAGS="mysql?,postgres?"
-DBTYPES=${DBFLAGS//\?/}
-DBTYPES=${DBTYPES//,/ }
-
-AUTHFLAGS="imap?,ldap?,odbc?"
-AUTHMODES=${AUTHFLAGS//\?/}
-AUTHMODES=${AUTHMODES//,/ }
-
-PHPFLAGS="ctype,curl,gd,iconv,ssl,tokenizer,xml,xmlrpc,zlib"
-
-IUSE="${DBTYPES} ${AUTHMODES} vhosts"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND=">=dev-lang/php-4.3.0[${DBFLAGS},${AUTHFLAGS},${PHPFLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DBCOUNT=0
- for db in ${DBTYPES}; do
- if use ${db}; then
- MYDB=${db}
- DBCOUNT=$(($DBCOUNT+1))
- fi
- done
-
- if [[ ${DBCOUNT} -eq 0 ]]; then
- eerror
- eerror "\033[1;31m**************************************************\033[1;31m"
- eerror "No database selected in your USE flags,"
- eerror "You must select at least one."
- eerror "\033[1;31m**************************************************\033[1;31m"
- eerror
- die
- fi
-
- if [[ ${DBCOUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- #
- # Moodle expect postgres7, not postgres
- #
- MYDB=${MYDB/postgres/postgres7}
- if [[ ${DBCOUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT} || die "Unable to insinto ${MOODLEROOT}"
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DBCOUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-1.9.9-r1.ebuild b/www-apps/moodle/moodle-1.9.9-r1.ebuild
deleted file mode 100644
index 2265cc72b499..000000000000
--- a/www-apps/moodle/moodle-1.9.9-r1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-1.9.9-r1.ebuild,v 1.1 2010/08/13 19:04:30 blueness Exp $
-
-EAPI="2"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-#SLOT empty due to webapp
-
-DBFLAGS="mysql?,postgres?"
-DBTYPES=${DBFLAGS//\?/}
-DBTYPES=${DBTYPES//,/ }
-
-AUTHFLAGS="imap?,ldap?,odbc?"
-AUTHMODES=${AUTHFLAGS//\?/}
-AUTHMODES=${AUTHMODES//,/ }
-
-PHPFLAGS="ctype,curl,gd,iconv,ssl,tokenizer,xml,xmlrpc,zlib"
-
-IUSE="${DBTYPES} ${AUTHMODES} vhosts"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND=">=dev-lang/php-4.3.0[${DBFLAGS},${AUTHFLAGS},${PHPFLAGS}]
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DBCOUNT=0
- for db in ${DBTYPES}; do
- if use ${db}; then
- MYDB=${db}
- DBCOUNT=$(($DBCOUNT+1))
- fi
- done
-
- if [[ ${DBCOUNT} -eq 0 ]]; then
- eerror
- eerror "\033[1;31m**************************************************\033[1;31m"
- eerror "No database selected in your USE flags,"
- eerror "You must select at least one."
- eerror "\033[1;31m**************************************************\033[1;31m"
- eerror
- die
- fi
-
- if [[ ${DBCOUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- #
- # Moodle expect postgres7, not postgres
- #
- MYDB=${MYDB/postgres/postgres7}
- if [[ ${DBCOUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT} || die "Unable to insinto ${MOODLEROOT}"
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DBCOUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-1.9.9.ebuild b/www-apps/moodle/moodle-1.9.9.ebuild
deleted file mode 100644
index 96eb6af3a6f5..000000000000
--- a/www-apps/moodle/moodle-1.9.9.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-1.9.9.ebuild,v 1.2 2010/07/19 15:42:16 mr_bones_ Exp $
-
-EAPI="2"
-
-inherit versionator webapp depend.php
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-DBTYPES="mysql postgres"
-AUTHMODES="imap ldap odbc radius"
-PHPFLAGS="${DBTYPES} ${AUTHMODES}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-#SLOT empty due to webapp
-IUSE="${PHPFLAGS} vhosts"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="virtual/cron"
-
-need_php5_httpd
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DBCOUNT=0
- for db in ${DBTYPES}; do
- if use ${db}; then
- MYDB=${db}
- DBCOUNT=$(($DBCOUNT+1))
- fi
- done
-
- if [[ ${DBCOUNT} -ne 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn "No db, or multiple dbs, selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn
- fi
-
- local flags="ctype curl gd iconv ssl tokenizer xml xmlrpc zlib"
-
- for flg in ${PHPFLAGS}; do
- if use ${flg}; then
- flags="${flags} ${flg}"
- fi
- done
-
- if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} ; then
- eerror
- eerror "\033[1;31m************************************************************\033[1;31m"
- eerror "Re-install ${PHP_PKG} with the following flags:"
- eerror " ${flags}"
- eerror "\033[1;31m************************************************************\033[1;31m"
- eerror
- die
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- #
- # Moodle expect postgres7, not postgres
- #
- MYDB=${MYDB/postgres/postgres7}
- if [[ ${DBCOUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT} || die "Unable to insinto ${MOODLEROOT}"
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DBCOUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PV}"
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
-}
diff --git a/www-apps/moodle/moodle-2.0.1.ebuild b/www-apps/moodle/moodle-2.0.1.ebuild
deleted file mode 100644
index b3c205dfba40..000000000000
--- a/www-apps/moodle/moodle-2.0.1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moodle/moodle-2.0.1.ebuild,v 1.1 2011/01/08 23:21:15 blueness Exp $
-
-EAPI="2"
-
-inherit versionator webapp
-
-AVC=( $(get_version_components) )
-MY_BRANCH="stable${AVC[0]}${AVC[1]}"
-
-DESCRIPTION="The Moodle Course Management System"
-HOMEPAGE="http://moodle.org"
-SRC_URI="http://download.moodle.org/${MY_BRANCH}/${P}.tgz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-#SLOT empty due to webapp
-
-DB_FLAGS="mysqli?,postgres?"
-DB_TYPES=${DB_FLAGS//\?/}
-DB_TYPES=${DB_TYPES//,/ }
-
-AUTHENTICATION_FLAGS="imap?,ldap?,odbc?"
-AUTHENTICATION_MODES=${AUTHENTICATION_FLAGS//\?/}
-AUTHENTICATION_MODES=${AUTHENTICATION_MODES//,/ }
-
-PHP_REQUIRED_FLAGS_52="ctype,curl,iconv,json,pcre,simplexml,spl,xml,zip"
-PHP_OPTIONAL_FLAGS_52="gd,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS_52="${PHP_REQUIRED_FLAGS_52},${PHP_OPTIONAL_FLAGS_52}"
-
-PHP_REQUIRED_FLAGS_53="ctype,curl,iconv,json,simplexml,xml,zip"
-PHP_OPTIONAL_FLAGS_53="gd,intl,soap,ssl,tokenizer,xmlrpc"
-PHP_FLAGS_53="${PHP_REQUIRED_FLAGS_53},${PHP_OPTIONAL_FLAGS_53}"
-
-IUSE="${DB_TYPES} ${AUTHENTICATION_MODES} vhosts"
-
-# No forced dependency on
-# mysql? ( virtual/mysql )
-# postgres? ( dev-db/postgresql-server-7* )
-# which may live on another server
-DEPEND=""
-RDEPEND="
- || (
- =dev-lang/php-5.2*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS_52}]
- =dev-lang/php-5.3*[${DB_FLAGS},${AUTHENTICATION_FLAGS},${PHP_FLAGS_53}]
- )
- virtual/httpd-php
- virtual/cron"
-
-pkg_setup() {
- webapp_pkg_setup
-
- # How many dbs were selected? If one and only one, which one is it?
- MYDB=""
- DB_COUNT=0
- for db in ${DB_TYPES}; do
- if use ${db}; then
- MYDB=${db}
- DB_COUNT=$(($DB_COUNT+1))
- fi
- done
-
- if [[ ${DB_COUNT} -eq 0 ]]; then
- eerror
- eerror "\033[1;31m**************************************************\033[1;31m"
- eerror "No database selected in your USE flags,"
- eerror "You must select at least one."
- eerror "\033[1;31m**************************************************\033[1;31m"
- eerror
- die
- fi
-
- if [[ ${DB_COUNT} -gt 1 ]]; then
- MYDB=""
- ewarn
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn "Multiple databases selected in your USE flags,"
- ewarn "You will have to choose your database manually."
- ewarn "\033[1;33m**************************************************\033[1;33m"
- ewarn
- fi
-}
-
-src_prepare() {
- rm COPYING.txt
- cp "${FILESDIR}"/config.php .
-
- # Moodle expect postgres7, not postgres
- MYDB=${MYDB/postgres/postgres7}
-
- # Moodle expects mysql, not mysqli
- MYDB=${MYDB/mysqli/mysql}
-
- if [[ ${DB_COUNT} -eq 1 ]] ; then
- sed -i -e "s|mydb|${MYDB}|" config.php
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- local MOODLEDATA="${MY_HOSTROOTDIR}"/moodle
- dodir ${MOODLEDATA}
- webapp_serverowned -R "${MOODLEDATA}"
-
- local MOODLEROOT="${MY_HTDOCSDIR}"
- insinto ${MOODLEROOT} || die "Unable to insinto ${MOODLEROOT}"
- doins -r *
-
- webapp_configfile "${MOODLEROOT}"/config.php
-
- if [[ ${DB_COUNT} -eq 1 ]]; then
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- else
- webapp_postinst_txt en "${FILESDIR}"/postinstall-nodb-en.txt
- fi
-
- webapp_src_install
-}
-
-pkg_postinst() {
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
- einfo "To see the post install instructions, do"
- einfo
- einfo " webapp-config --show-postinst ${PN} ${PVR}"
- einfo
- einfo "\033[1;32m**************************************************\033[1;32m"
- einfo
-}