summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-25 18:45:23 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-25 18:45:23 +0000
commit23655d7aaff04df2dc1f00db456f28ed73fab91f (patch)
tree89df9bc9b679493c4403702406a90a4d6cd24083 /www-apps/drupal
parentVersion bump. (diff)
downloadgentoo-2-23655d7aaff04df2dc1f00db456f28ed73fab91f.tar.gz
gentoo-2-23655d7aaff04df2dc1f00db456f28ed73fab91f.tar.bz2
gentoo-2-23655d7aaff04df2dc1f00db456f28ed73fab91f.zip
Version bump, bug #252252, thank Tom Rogie aka Trogie for report.
(Portage version: 2.1.6.2/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/ChangeLog9
-rw-r--r--www-apps/drupal/drupal-5.14.ebuild51
-rw-r--r--www-apps/drupal/drupal-6.8.ebuild56
3 files changed, 115 insertions, 1 deletions
diff --git a/www-apps/drupal/ChangeLog b/www-apps/drupal/ChangeLog
index 362a7a86c552..c36fad059922 100644
--- a/www-apps/drupal/ChangeLog
+++ b/www-apps/drupal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/drupal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.54 2008/12/12 23:11:48 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/ChangeLog,v 1.55 2008/12/25 18:45:23 pva Exp $
+
+*drupal-6.8 (25 Dec 2008)
+*drupal-5.14 (25 Dec 2008)
+
+ 25 Dec 2008; Peter Volkov <pva@gentoo.org> +drupal-5.14.ebuild,
+ +drupal-6.8.ebuild:
+ Version bump, bug #252252, thank Tom Rogie aka Trogie for report.
*drupal-6.7 (12 Dec 2008)
*drupal-5.13 (12 Dec 2008)
diff --git a/www-apps/drupal/drupal-5.14.ebuild b/www-apps/drupal/drupal-5.14.ebuild
new file mode 100644
index 000000000000..872d01d1e1d5
--- /dev/null
+++ b/www-apps/drupal/drupal-5.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-5.14.ebuild,v 1.1 2008/12/25 18:45:23 pva Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ require_php_with_use expat
+ else
+ require_php_with_use xml
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt"
+ dodoc ${docs}
+ rm -f ${docs} INSTALL
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/drupal/drupal-6.8.ebuild b/www-apps/drupal/drupal-6.8.ebuild
new file mode 100644
index 000000000000..db9d4635db9c
--- /dev/null
+++ b/www-apps/drupal/drupal-6.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-6.8.ebuild,v 1.1 2008/12/25 18:45:23 pva Exp $
+
+inherit webapp eutils depend.php
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [[ ${PHP_VERSION} == "4" ]] ; then
+ local flags="expat"
+ else
+ local flags="xml"
+ fi
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt
+
+ cp sites/default/{default.settings.php,settings.php}
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}