summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-26 09:39:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-26 09:39:33 +0000
commit31cde7f0dc9dc712beaa037505e36066aacaa750 (patch)
tree87c4dc922b5e80275d67ad29b5aa7111ac417a24 /www-apps/davical
parentBump (diff)
downloadgentoo-2-31cde7f0dc9dc712beaa037505e36066aacaa750.tar.gz
gentoo-2-31cde7f0dc9dc712beaa037505e36066aacaa750.tar.bz2
gentoo-2-31cde7f0dc9dc712beaa037505e36066aacaa750.zip
Bump for #423603
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/davical')
-rw-r--r--www-apps/davical/ChangeLog8
-rw-r--r--www-apps/davical/davical-1.1.0.ebuild77
2 files changed, 83 insertions, 2 deletions
diff --git a/www-apps/davical/ChangeLog b/www-apps/davical/ChangeLog
index f9ffc8133bc4..e1fb4f21966f 100644
--- a/www-apps/davical/ChangeLog
+++ b/www-apps/davical/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/davical
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/ChangeLog,v 1.1 2012/03/14 06:46:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/ChangeLog,v 1.2 2012/06/26 09:39:33 patrick Exp $
+
+*davical-1.1.0 (26 Jun 2012)
+
+ 26 Jun 2012; Patrick Lauer <patrick@gentoo.org> +davical-1.1.0.ebuild:
+ Bump for #423603
12 Mar 2012; lebarjack <francois.perichon@univ-lille2.fr>
-davical-1.0.2.ebuild, +davical-1.0.2-r1.ebuild:
@@ -135,4 +140,3 @@
+davical-0.9.5.ebuild, +files/postinstall-en-0.9.5.txt,
+files/driver_ldap.patch, +files/rscds.conf, +metadata.xml:
New ebuild for bug 195118 - (initial work by Cory Coager <ccoager@gmail.com>)
-
diff --git a/www-apps/davical/davical-1.1.0.ebuild b/www-apps/davical/davical-1.1.0.ebuild
new file mode 100644
index 000000000000..7f1deca5a3cb
--- /dev/null
+++ b/www-apps/davical/davical-1.1.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/davical/davical-1.1.0.ebuild,v 1.1 2012/06/26 09:39:33 patrick Exp $
+
+EAPI=2
+
+inherit depend.php webapp
+
+DESCRIPTION="A CalDAV and CardDAV Server"
+HOMEPAGE="http://davical.org/"
+SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="app-admin/pwgen
+ dev-lang/php[calendar,curl,pdo,postgres,xml]
+ dev-perl/DBI
+ dev-perl/DBD-Pg
+ dev-perl/yaml
+ >=dev-php/awl-0.51
+ www-servers/apache"
+
+need_php5
+need_httpd
+
+src_prepare() {
+ epatch "${FILESDIR}/awl_location.patch"
+ epatch "${FILESDIR}/inc_path.patch"
+}
+
+src_compile() {
+ if use doc ; then
+ einfo "Generating documentation"
+ phpdoc -q -c "docs/api/phpdoc.ini"\
+ || die "Documentation failed to build"
+ fi
+ emake built-po || die "emake failed"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc-php INSTALL README debian/README.Debian \
+ testing/README.regression_tests TODO debian/changelog \
+ || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/* htdocs/.htaccess || die "doins failed"
+
+ einfo "Installing main files and i18n"
+ insinto "${MY_HOSTROOTDIR}/${PN}"
+ doins -r inc locale || die "doins failed"
+ rm "${D}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r dba/* || die "doins failed"
+
+ if use doc ; then
+ einfo "Installing documentation"
+ dohtml -r docs/api/ docs/website/ || die "dohtml failed"
+ fi
+
+ insinto /etc/${PN}
+ doins config/* "${FILESDIR}/vhost-example" \
+ || die "newins failed"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
+}