summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-06-24 13:18:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-06-24 13:18:15 +0000
commit3770cc3b31d3142d62eb3a81370fb3b095935579 (patch)
treed2160020ad67939c4dbccc99290d6ebedc4220c6 /www-apps/bugzilla
parentStable for HPPA (bug #272692). (diff)
downloadgentoo-2-3770cc3b31d3142d62eb3a81370fb3b095935579.tar.gz
gentoo-2-3770cc3b31d3142d62eb3a81370fb3b095935579.tar.bz2
gentoo-2-3770cc3b31d3142d62eb3a81370fb3b095935579.zip
Version bump for security bugs 257923 and 258592. Request itself is in bug 273821. de lingua commented cause not able to test. This is non-maintainer commit.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-apps/bugzilla')
-rw-r--r--www-apps/bugzilla/ChangeLog10
-rw-r--r--www-apps/bugzilla/bugzilla-3.2.3.ebuild105
2 files changed, 114 insertions, 1 deletions
diff --git a/www-apps/bugzilla/ChangeLog b/www-apps/bugzilla/ChangeLog
index 1b6c42d7b6c9..d848213d64ff 100644
--- a/www-apps/bugzilla/ChangeLog
+++ b/www-apps/bugzilla/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/bugzilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.128 2009/05/26 17:57:16 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.129 2009/06/24 13:18:15 scarabeus Exp $
+
+*bugzilla-3.2.3 (24 Jun 2009)
+
+ 24 Jun 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +bugzilla-3.2.3.ebuild:
+ Version bump for security bugs 257923 and 258592. Request itself is in bug
+ 273821. de lingua commented cause not able to test. This is non-maintainer
+ commit.
26 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
bugzilla-2.20.6.ebuild, bugzilla-2.22.5.ebuild:
diff --git a/www-apps/bugzilla/bugzilla-3.2.3.ebuild b/www-apps/bugzilla/bugzilla-3.2.3.ebuild
new file mode 100644
index 000000000000..f683f3178f2b
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-3.2.3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.2.3.ebuild,v 1.1 2009/06/24 13:18:15 scarabeus Exp $
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=3.0
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+# linguas_de? ( http://ganderbay.net/dl/germzilla-${PV}-1.utf-8.tar.gz )"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="modperl extras graphviz mysql postgres" # linguas_de"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.8.0
+
+ >=dev-perl/DBI-1.41
+ >=dev-perl/Email-MIME-1.861
+ >=dev-perl/Email-MIME-Modifier-1.442
+ >=dev-perl/Email-Send-2.16
+ >=dev-perl/MIME-tools-5.406
+ >=dev-perl/Template-Toolkit-2.15
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-3.21
+ >=virtual/perl-File-Spec-0.84
+ >=virtual/perl-MIME-Base64-3.01
+
+ mysql? ( >=dev-perl/DBD-mysql-4.00 )
+ postgres? ( >=dev-perl/DBD-Pg-1.45 )
+ graphviz? ( media-gfx/graphviz )
+
+ modperl? (
+ >=dev-perl/Apache-DBI-0.96
+ >=virtual/perl-CGI-3.21
+ =www-apache/mod_perl-2*
+ )
+
+ extras? (
+ dev-perl/Authen-SASL
+ >=dev-perl/Chart-1.0
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ >=dev-perl/GD-1.20
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ >=dev-perl/HTML-Parser-3.40
+ dev-perl/HTML-Scrubber
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/perl-ldap
+ dev-perl/SOAP-Lite
+ dev-perl/Template-GD
+ dev-perl/XML-Twig
+ )
+"
+
+want_apache modperl
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ webapp_pkg_setup
+
+ if use extras ; then
+ if ! has_version media-gfx/imagemagick || ! built_with_use media-gfx/imagemagick perl ; then
+ elog "Consider installing media-gfx/imagemagick with USE=\"perl\""
+ elog "to convert BMP attachments to PNG"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+
+# if use linguas_de ; then
+# mv ../de template/
+# elog "Installing German translation pack"
+# elog "Be sure to read http://wiki.ganderbay.net/wde/Germzilla-Installation"
+# elog "for installation instructions"
+# fi
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f}
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+}