summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-10-11 19:42:59 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-10-11 19:42:59 +0000
commitebf6a7d05f48b94124dc4cd7479c0088cece832e (patch)
treed0d825d8da226f677502fa5f162d784c2e984a87 /www-apps/bugzilla/bugzilla-2.22.5.ebuild
parentVersion bump, removed -j1 as it was fixed upstream. Made installable with gim... (diff)
downloadgentoo-2-ebf6a7d05f48b94124dc4cd7479c0088cece832e.tar.gz
gentoo-2-ebf6a7d05f48b94124dc4cd7479c0088cece832e.tar.bz2
gentoo-2-ebf6a7d05f48b94124dc4cd7479c0088cece832e.zip
Added bugzilla-2.22.5, -3.0.5 in response to sec issue #239564.
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/bugzilla/bugzilla-2.22.5.ebuild')
-rw-r--r--www-apps/bugzilla/bugzilla-2.22.5.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/www-apps/bugzilla/bugzilla-2.22.5.ebuild b/www-apps/bugzilla/bugzilla-2.22.5.ebuild
new file mode 100644
index 000000000000..6f8524c99029
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-2.22.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-2.22.5.ebuild,v 1.1 2008/10/11 19:42:59 wrobel Exp $
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="extras graphviz mysql postgres"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.6.1
+
+ >=dev-perl/AppConfig-1.52
+ >=dev-perl/DBI-1.38
+ >=dev-perl/MailTools-1.67
+ dev-perl/MIME-tools
+ >=dev-perl/Template-Toolkit-2.13
+ >=dev-perl/Text-Tabs+Wrap-2001.0131
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-2.93
+ >=virtual/perl-File-Spec-0.84
+ virtual/perl-File-Temp
+ >=virtual/perl-MIME-Base64-3.01
+ virtual/perl-Storable
+
+ extras? (
+ >=dev-perl/Chart-2.3
+ >=dev-perl/GD-1.20
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ dev-perl/HTML-Scrubber
+ >=dev-perl/PatchReader-0.9.4
+ dev-perl/perl-ldap
+ dev-perl/Template-GD
+ dev-perl/XML-Twig
+ dev-util/patchutils
+ )
+
+ graphviz? ( media-gfx/graphviz )
+ mysql? ( >=dev-perl/DBD-mysql-3.0007 )
+ postgres? ( >=dev-perl/DBD-Pg-1.45 )
+"
+
+need_apache2
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ ecvs_clean
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ newins "${FILESDIR}"/${MY_PB}/apache.htaccess .htaccess
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f}
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+}