summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-17 21:00:56 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-17 21:00:56 +0000
commit745171326fb0a895124451c00b835d684d1b1fb5 (patch)
treeb5eab877d790ca7c2ccd5f9fb1e4624b0eec51b0 /www-apps/bugport
parentRemove old (diff)
downloadgentoo-2-745171326fb0a895124451c00b835d684d1b1fb5.tar.gz
gentoo-2-745171326fb0a895124451c00b835d684d1b1fb5.tar.bz2
gentoo-2-745171326fb0a895124451c00b835d684d1b1fb5.zip
merge from webapp overlay
(Portage version: 2.1.4.1)
Diffstat (limited to 'www-apps/bugport')
-rw-r--r--www-apps/bugport/ChangeLog14
-rw-r--r--www-apps/bugport/bugport-1.146.ebuild6
-rw-r--r--www-apps/bugport/bugport-1.147.ebuild65
3 files changed, 80 insertions, 5 deletions
diff --git a/www-apps/bugport/ChangeLog b/www-apps/bugport/ChangeLog
index 3129d67e1765..644d4b4739cd 100644
--- a/www-apps/bugport/ChangeLog
+++ b/www-apps/bugport/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-apps/bugport
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/ChangeLog,v 1.6 2007/12/25 14:38:22 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/ChangeLog,v 1.7 2008/02/17 21:00:56 hollow Exp $
+
+*bugport-1.147 (17 Feb 2008)
+
+ 17 Feb 2008; Benedikt Böhm <hollow@gentoo.org> bugport-1.146.ebuild,
+ +bugport-1.147.ebuild:
+ merge from webapp overlay
+
+ 05 Feb 2008; Jakub Moc <jakub@gentoo.org> +bugport-1.147.ebuild:
+ Version bump. Fix dependencies, add mysql USE flag and check for required
+ PHP features accordingly. Quoting, ebuild cleanup.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing pyrania from metadata.xml as per #26352. Assigning to
diff --git a/www-apps/bugport/bugport-1.146.ebuild b/www-apps/bugport/bugport-1.146.ebuild
index 58b83c692794..b11e58f4e525 100644
--- a/www-apps/bugport/bugport-1.146.ebuild
+++ b/www-apps/bugport/bugport-1.146.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/bugport-1.146.ebuild,v 1.2 2007/08/05 01:21:27 jmglov Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/bugport-1.146.ebuild,v 1.3 2008/02/17 21:00:56 hollow Exp $
inherit webapp
@@ -54,7 +54,7 @@ src_install() {
conf/config.php
# Install
- cp -R . ${D}${MY_HTDOCSDIR}
+ cp -R . "${D}"${MY_HTDOCSDIR}
# Identify the configuration files that this app uses
webapp_configfile ${MY_HTDOCSDIR}/conf/config.php
diff --git a/www-apps/bugport/bugport-1.147.ebuild b/www-apps/bugport/bugport-1.147.ebuild
new file mode 100644
index 000000000000..2bb550c08b85
--- /dev/null
+++ b/www-apps/bugport/bugport-1.147.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/bugport-1.147.ebuild,v 1.1 2008/02/17 21:00:56 hollow Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Web-based system for managing tasks and defects throughout the software development process"
+HOMEPAGE="http://www.incogen.com/index.php?type=General&param=bugport"
+SRC_URI="http://www.incogen.com/downloads/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql"
+
+DEPEND="dev-php/adodb"
+
+need_php_httpd
+
+S=${WORKDIR}/${PN}_${PV}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+
+ if use mysql ; then
+ require_php_with_use mysql
+ else
+ elog "It is your responsibility to ensure that you have configured"
+ elog "${PHP_PKG} for use with dev-php/adodb and your DB of choice"
+ elog "and will handle creating the required DB tables for the chosen DB."
+ elog "If that's not what you want, re-emerge ${P} with USE=mysql."
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Fix INSTALL.txt to let the user know where the SQL scripts live
+ sed -i -e "s|create_tables.sql|${MY_SQLSCRIPTSDIR}/mysql/${PV}_create.sql|" \
+ INSTALL.txt || die "sed failed in INSTALL.txt"
+
+ webapp_postinst_txt en INSTALL.txt
+
+ local dbfiles="add_indices.sql alter_user_table.sql create_config_table.sql create_tables.sql"
+ for i in ${dbfiles} ; do
+ use mysql && webapp_sqlscript mysql ${i} || dodoc ${i}
+ done
+ rm -f *.sql
+
+ dodoc *.txt
+ docinto devel-docs
+ dodoc devel-docs/*
+ rm -rf *.txt devel-docs install-gentoo-unsupported
+
+ # Fix config file to know where to find adodb
+ sed -i -e 's|^\(# \+\)\?\$adoDir.\+$|$adoDir = "/usr/lib/php/adodb/"; # DO NOT CHANGE!|' \
+ conf/config.php || die "failed to fix adodb location in config.php."
+
+ cp -R . "${D}"${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.php
+ webapp_configfile ${MY_HTDOCSDIR}/conf/configuration.php
+
+ webapp_src_install
+}