summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-18 11:23:48 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-18 11:23:48 +0000
commit44afc04f215222b7cb04eb5a7e59dfdb2628b8cb (patch)
tree75e1d82664d3ab1af8bbc2919ff175279af99297 /www-apps/bugport
parentInitial import. (diff)
downloadgentoo-2-44afc04f215222b7cb04eb5a7e59dfdb2628b8cb.tar.gz
gentoo-2-44afc04f215222b7cb04eb5a7e59dfdb2628b8cb.tar.bz2
gentoo-2-44afc04f215222b7cb04eb5a7e59dfdb2628b8cb.zip
fix stable ebuild too wrt #208584; cleanup
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps/bugport')
-rw-r--r--www-apps/bugport/ChangeLog6
-rw-r--r--www-apps/bugport/bugport-1.146.ebuild55
-rw-r--r--www-apps/bugport/bugport-1.147.ebuild16
3 files changed, 34 insertions, 43 deletions
diff --git a/www-apps/bugport/ChangeLog b/www-apps/bugport/ChangeLog
index 70af3b8c011a..73ca5345e583 100644
--- a/www-apps/bugport/ChangeLog
+++ b/www-apps/bugport/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/bugport
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/ChangeLog,v 1.8 2008/02/17 23:31:18 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/ChangeLog,v 1.9 2008/02/18 11:23:48 hollow Exp $
+
+ 18 Feb 2008; Benedikt Böhm <hollow@gentoo.org> bugport-1.146.ebuild,
+ bugport-1.147.ebuild:
+ fix stable ebuild too wrt #208584; cleanup
17 Feb 2008; Benedikt Böhm <hollow@gentoo.org> metadata.xml:
fix metadata
diff --git a/www-apps/bugport/bugport-1.146.ebuild b/www-apps/bugport/bugport-1.146.ebuild
index b11e58f4e525..38b20b2f55b0 100644
--- a/www-apps/bugport/bugport-1.146.ebuild
+++ b/www-apps/bugport/bugport-1.146.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/bugport-1.146.ebuild,v 1.3 2008/02/17 21:00:56 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/bugport-1.146.ebuild,v 1.4 2008/02/18 11:23:48 hollow Exp $
-inherit webapp
+inherit webapp depend.php
DESCRIPTION="Web-based system for managing tasks and defects throughout the software development process"
HOMEPAGE="http://www.incogen.com/index.php?type=General&param=bugport"
@@ -10,56 +10,45 @@ SRC_URI="http://www.incogen.com/downloads/${PN}/${PN}_${PV}.tar.gz"
LICENSE="BSD"
KEYWORDS="x86 ~ppc"
-
IUSE=""
-RDEPEND=">=virtual/php-4.3
- dev-php/adodb"
-DEPEND=""
+
+DEPEND="dev-php/adodb"
+
+need_php_httpd
S=${WORKDIR}/${PN}_${PV}
-src_compile() {
- einfo "Nothing to compile"
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use mysql
}
src_install() {
- # prepare ${D} for our arrival
webapp_src_preinst
- # Fix INSTALL.txt to let the user know where the SQL scripts live
- sed -i \
- -e "s|create_tables.sql|${MY_SQLSCRIPTSDIR}/mysql/${PV}_create.sql|" \
- INSTALL.txt
+ # fix INSTALL.txt to let the user know where the SQL scripts live
+ sed -i -e "s|create_tables.sql|${MY_SQLSCRIPTSDIR}/mysql/${PV}_create.sql|" \
+ INSTALL.txt || die "sed failed in INSTALL.txt"
- # Add the post-installation instructions
- webapp_postinst_txt en INSTALL.txt
+ webapp_sqlscript mysql create_tables.sql
+ rm -f *.sql
- # Install documents
dodoc *.txt
- rm *.txt
docinto devel-docs
dodoc devel-docs/*
- rm -rf devel-docs
- rm -rf install-gentoo-unsupported
-
- # Install SQL scripts
- #webapp_sqlscript mysql add_indices.sql
- #webapp_sqlscript mysql alter_user_table.sql
- #webapp_sqlscript mysql create_config_table.sql
- webapp_sqlscript mysql create_tables.sql
+ rm -rf *.txt devel-docs install-gentoo-unsupported
- # Fix config file to know where to find adodb
- sed -i \
- -e 's|^\(# \+\)\?\$adoDir.\+$|$adoDir = "/usr/lib/php/adodb/"; # DO NOT CHANGE!|' \
- conf/config.php
+ # fix config file to know where to find adodb
+ sed -i -e 's|^\(# \+\)\?\$adoDir.\+$|$adoDir = "/usr/lib/php/adodb/"; # DO NOT CHANGE!|' \
+ conf/config.php || die "failed to fix adodb location in config.php."
- # Install
- cp -R . "${D}"${MY_HTDOCSDIR}
+ insinto ${MY_HTDOCSDIR}
+ doins -r .
- # Identify the configuration files that this app uses
webapp_configfile ${MY_HTDOCSDIR}/conf/config.php
webapp_configfile ${MY_HTDOCSDIR}/conf/configuration.php
- # Let webapp.eclass do the rest
+ webapp_postinst_txt en INSTALL.txt
webapp_src_install
}
diff --git a/www-apps/bugport/bugport-1.147.ebuild b/www-apps/bugport/bugport-1.147.ebuild
index 2bb550c08b85..209c86818890 100644
--- a/www-apps/bugport/bugport-1.147.ebuild
+++ b/www-apps/bugport/bugport-1.147.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/bugport-1.147.ebuild,v 1.1 2008/02/17 21:00:56 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugport/bugport-1.147.ebuild,v 1.2 2008/02/18 11:23:48 hollow Exp $
inherit webapp depend.php
@@ -21,7 +21,6 @@ S=${WORKDIR}/${PN}_${PV}
pkg_setup() {
webapp_pkg_setup
has_php
-
if use mysql ; then
require_php_with_use mysql
else
@@ -35,14 +34,11 @@ pkg_setup() {
src_install() {
webapp_src_preinst
- # Fix INSTALL.txt to let the user know where the SQL scripts live
+ # fix INSTALL.txt to let the user know where the SQL scripts live
sed -i -e "s|create_tables.sql|${MY_SQLSCRIPTSDIR}/mysql/${PV}_create.sql|" \
INSTALL.txt || die "sed failed in INSTALL.txt"
- webapp_postinst_txt en INSTALL.txt
-
- local dbfiles="add_indices.sql alter_user_table.sql create_config_table.sql create_tables.sql"
- for i in ${dbfiles} ; do
+ for i in add_indices.sql alter_user_table.sql create_config_table.sql create_tables.sql; do
use mysql && webapp_sqlscript mysql ${i} || dodoc ${i}
done
rm -f *.sql
@@ -52,14 +48,16 @@ src_install() {
dodoc devel-docs/*
rm -rf *.txt devel-docs install-gentoo-unsupported
- # Fix config file to know where to find adodb
+ # fix config file to know where to find adodb
sed -i -e 's|^\(# \+\)\?\$adoDir.\+$|$adoDir = "/usr/lib/php/adodb/"; # DO NOT CHANGE!|' \
conf/config.php || die "failed to fix adodb location in config.php."
- cp -R . "${D}"${MY_HTDOCSDIR}
+ insinto ${MY_HTDOCSDIR}
+ doins -r .
webapp_configfile ${MY_HTDOCSDIR}/conf/config.php
webapp_configfile ${MY_HTDOCSDIR}/conf/configuration.php
+ webapp_postinst_txt en INSTALL.txt
webapp_src_install
}