summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-07-07 19:02:28 +0000
committerMike Gilbert <floppym@gentoo.org>2012-07-07 19:02:28 +0000
commitf2e1156057aa4df9258d77f762a5fdf11d6433a0 (patch)
tree5ec8f2d138e189a6ab50a3660f355d7eae3f3c48 /www-apache
parent[bump] dev-perl/crypt-dh-0.70.0. Use Math-BigInt-GMP instead of math-pari (diff)
downloadgentoo-2-f2e1156057aa4df9258d77f762a5fdf11d6433a0.tar.gz
gentoo-2-f2e1156057aa4df9258d77f762a5fdf11d6433a0.tar.bz2
gentoo-2-f2e1156057aa4df9258d77f762a5fdf11d6433a0.zip
Fix build failure with Boost 1.50. Patch by Arfrever.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/anyterm/ChangeLog9
-rw-r--r--www-apache/anyterm/anyterm-1.1.29.ebuild7
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch58
3 files changed, 68 insertions, 6 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
index 6c0671d2b993..3bc8572d5752 100644
--- a/www-apache/anyterm/ChangeLog
+++ b/www-apache/anyterm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/anyterm
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.22 2009/12/12 03:54:34 arfrever Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.23 2012/07/07 19:02:28 floppym Exp $
+
+ 07 Jul 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/anyterm-1.1.29-boost-1.50.patch, anyterm-1.1.29.ebuild:
+ Fix build failure with Boost 1.50. Patch by Arfrever.
12 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
anyterm-1.1.29.ebuild:
@@ -122,4 +126,3 @@
+files/anyterm-1.1.8-libpbe-no-pg_config.patch, +metadata.xml,
+anyterm-1.1.8.ebuild:
Initial version. Bug # 98647.
-
diff --git a/www-apache/anyterm/anyterm-1.1.29.ebuild b/www-apache/anyterm/anyterm-1.1.29.ebuild
index d20999d6ff5a..0ffecc1b27c9 100644
--- a/www-apache/anyterm/anyterm-1.1.29.ebuild
+++ b/www-apache/anyterm/anyterm-1.1.29.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.29.ebuild,v 1.2 2009/12/12 03:54:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.29.ebuild,v 1.3 2012/07/07 19:02:28 floppym Exp $
EAPI="2"
@@ -22,10 +22,11 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}/${PN}-1.1.28-respect-LDFLAGS.patch"
epatch "${FILESDIR}/${P}-gcc-4.4.patch"
+ epatch "${FILESDIR}/${P}-boost-1.50.patch"
}
src_compile() {
- # this package uses `ld -r -b binary` and thus resulting executalbe contains
+ # this package uses `ld -r -b binary` and thus resulting executable contains
# executable stack
append-ldflags -Wl,-z,noexecstack
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
diff --git a/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch b/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch
new file mode 100644
index 000000000000..b0648a9e3067
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch
@@ -0,0 +1,58 @@
+Patch by Arfrever; sent to upstream developer.
+
+--- libpbe/src/parse_http_request.cc
++++ libpbe/src/parse_http_request.cc
+@@ -18,11 +18,11 @@
+
+ #include "parse_http_request.hh"
+
+-#include <boost/spirit.hpp>
+-#include <boost/spirit/actor/insert_at_actor.hpp>
+-#include <boost/spirit/dynamic/if.hpp>
+-#include <boost/spirit/utility/loops.hpp>
+-#include <boost/spirit/iterator/multi_pass.hpp>
++#include <boost/spirit/include/classic.hpp>
++#include <boost/spirit/include/classic_if.hpp>
++#include <boost/spirit/include/classic_insert_at_actor.hpp>
++#include <boost/spirit/include/classic_loops.hpp>
++#include <boost/spirit/include/classic_multi_pass.hpp>
+
+ #include <boost/lexical_cast.hpp>
+ #include <boost/scoped_array.hpp>
+@@ -31,7 +31,7 @@
+
+
+ using namespace std;
+-using namespace boost::spirit;
++using namespace boost::spirit::classic;
+
+
+ namespace pbe {
+--- libpbe/src/URI.cc
++++ libpbe/src/URI.cc
+@@ -18,11 +18,11 @@
+
+ #include "URI.hh"
+
+-#include <boost/spirit.hpp>
+-#include <boost/spirit/actor/insert_at_actor.hpp>
+-#include <boost/spirit/dynamic/if.hpp>
+-#include <boost/spirit/utility/loops.hpp>
+-#include <boost/spirit/iterator/multi_pass.hpp>
++#include <boost/spirit/include/classic.hpp>
++#include <boost/spirit/include/classic_if.hpp>
++#include <boost/spirit/include/classic_insert_at_actor.hpp>
++#include <boost/spirit/include/classic_loops.hpp>
++#include <boost/spirit/include/classic_multi_pass.hpp>
+
+ #include <boost/lexical_cast.hpp>
+ #include <boost/scoped_array.hpp>
+@@ -30,7 +30,7 @@
+ #include <map>
+
+ using namespace std;
+-using namespace boost::spirit;
++using namespace boost::spirit::classic;
+
+
+ namespace pbe {