summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-19 19:35:41 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-19 19:35:41 +0000
commit75dadad48d56a788de2cf004e19cad9e969868a0 (patch)
treedd07980948cc9652412b2a459e5ac8a56bb9bbeb /virtual
parentVersion bump, bug#537054 (diff)
downloadgentoo-2-75dadad48d56a788de2cf004e19cad9e969868a0.tar.gz
gentoo-2-75dadad48d56a788de2cf004e19cad9e969868a0.tar.bz2
gentoo-2-75dadad48d56a788de2cf004e19cad9e969868a0.zip
Add new versions for stable and unstable in the default slot to fix issues with some dependency resolvers.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/ruby-threads/ChangeLog12
-rw-r--r--virtual/ruby-threads/ruby-threads-6.ebuild29
-rw-r--r--virtual/ruby-threads/ruby-threads-7.ebuild30
3 files changed, 69 insertions, 2 deletions
diff --git a/virtual/ruby-threads/ChangeLog b/virtual/ruby-threads/ChangeLog
index 3f6b2358f9bd..92980e7bf01f 100644
--- a/virtual/ruby-threads/ChangeLog
+++ b/virtual/ruby-threads/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for virtual/ruby-threads
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ChangeLog,v 1.35 2014/10/10 09:02:07 graaff Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ChangeLog,v 1.36 2015/01/19 19:35:41 graaff Exp $
+
+*ruby-threads-7 (19 Jan 2015)
+*ruby-threads-6 (19 Jan 2015)
+
+ 19 Jan 2015; Hans de Graaff <graaff@gentoo.org> +ruby-threads-6.ebuild,
+ +ruby-threads-7.ebuild:
+ Add new versions for stable and unstable in the default slot to fix issues
+ with some dependency resolvers.
10 Oct 2014; Hans de Graaff <graaff@gentoo.org> -ruby-threads-2.ebuild:
Remove masked jruby 1.6 version.
diff --git a/virtual/ruby-threads/ruby-threads-6.ebuild b/virtual/ruby-threads/ruby-threads-6.ebuild
new file mode 100644
index 000000000000..7c851a8f8da0
--- /dev/null
+++ b/virtual/ruby-threads/ruby-threads-6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ruby-threads-6.ebuild,v 1.1 2015/01/19 19:35:41 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for a ruby interpreter with threading enabled"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~x64-macos"
+IUSE=""
+
+RDEPEND="
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9 )
+ ruby_targets_ruby20? ( dev-lang/ruby:2.0 )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }
diff --git a/virtual/ruby-threads/ruby-threads-7.ebuild b/virtual/ruby-threads/ruby-threads-7.ebuild
new file mode 100644
index 000000000000..af0a3f5dc4e0
--- /dev/null
+++ b/virtual/ruby-threads/ruby-threads-7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/ruby-threads/ruby-threads-7.ebuild,v 1.1 2015/01/19 19:35:41 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-ng
+
+DESCRIPTION="Virtual ebuild for a ruby interpreter with threading enabled"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-macos"
+IUSE=""
+
+RDEPEND="
+ ruby_targets_ruby19? ( dev-lang/ruby:1.9 )
+ ruby_targets_ruby20? ( dev-lang/ruby:2.0 )
+ ruby_targets_ruby21? ( dev-lang/ruby:2.1 )"
+
+pkg_setup() { :; }
+src_unpack() { :; }
+src_prepare() { :; }
+src_compile() { :; }
+src_install() { :; }
+pkg_preinst() { :; }
+pkg_postinst() { :; }