summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-08-01 21:38:00 +0000
committerBrian Evans <grknight@gentoo.org>2015-08-01 21:38:00 +0000
commit739779f6ad4981aec90bb93a4f129d2afb35613d (patch)
tree177cf18a29c10d8313bfbed17a771a8c434f25ce /virtual
parentDropped unused local USE-description: usenativewindowslibraries. Thanks to mr... (diff)
downloadgentoo-2-739779f6ad4981aec90bb93a4f129d2afb35613d.tar.gz
gentoo-2-739779f6ad4981aec90bb93a4f129d2afb35613d.tar.bz2
gentoo-2-739779f6ad4981aec90bb93a4f129d2afb35613d.zip
Revbump to take into account that only server packages have the embedded library and must be paired with client-libs for mysql_config
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/mysql/ChangeLog8
-rw-r--r--virtual/mysql/mysql-5.6-r6.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/virtual/mysql/ChangeLog b/virtual/mysql/ChangeLog
index f547d5185810..5391a3c87d4f 100644
--- a/virtual/mysql/ChangeLog
+++ b/virtual/mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for virtual/mysql
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/mysql/ChangeLog,v 1.64 2015/07/29 01:45:06 grknight Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/mysql/ChangeLog,v 1.65 2015/08/01 21:38:00 grknight Exp $
+
+*mysql-5.6-r6 (01 Aug 2015)
+
+ 01 Aug 2015; Brian Evans <grknight@gentoo.org> +mysql-5.6-r6.ebuild:
+ Revbump to take into account that only server packages have the embedded
+ library and must be paired with client-libs for mysql_config
*mysql-5.6-r5 (29 Jul 2015)
diff --git a/virtual/mysql/mysql-5.6-r6.ebuild b/virtual/mysql/mysql-5.6-r6.ebuild
new file mode 100644
index 000000000000..9065754daaa9
--- /dev/null
+++ b/virtual/mysql/mysql-5.6-r6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/mysql/mysql-5.6-r6.ebuild,v 1.1 2015/08/01 21:38:00 grknight Exp $
+
+EAPI="5"
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for MySQL database server"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0/18"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="embedded static static-libs"
+
+DEPEND=""
+RDEPEND="
+ virtual/libmysqlclient[static-libs?,${MULTILIB_USEDEP}]
+ embedded? (
+ || (
+ =dev-db/mariadb-10.1*[client-libs(+),embedded,static=]
+ =dev-db/mariadb-10.0*[client-libs(+),embedded,static=]
+ =dev-db/mysql-${PV}*[client-libs(+),embedded,static=]
+ =dev-db/percona-server-${PV}*[client-libs(+),embedded,static=]
+ =dev-db/mariadb-galera-10.0*[client-libs(+),embedded,static=]
+ =dev-db/mysql-cluster-7.3*[client-libs(+),embedded,static=]
+ )
+ )
+ !embedded? (
+ || (
+ =dev-db/mariadb-10.1*[-embedded,static=]
+ =dev-db/mariadb-10.0*[-embedded,static=]
+ =dev-db/mysql-${PV}*[-embedded,static=]
+ =dev-db/percona-server-${PV}*[-embedded,static=]
+ =dev-db/mariadb-galera-10.0*[-embedded,static=]
+ =dev-db/mysql-cluster-7.3*[-embedded,static=]
+ )
+ )
+"