summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-19 18:02:54 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-19 18:02:54 +0000
commit4fcb188c6f28233622b6441576e44070952f6d74 (patch)
treed9b2cdbaf444a29edc4e9a1ed2af3b916dfba64a /virtual/python-futures
parentrespect AR wrt #475144 (diff)
downloadgentoo-2-4fcb188c6f28233622b6441576e44070952f6d74.tar.gz
gentoo-2-4fcb188c6f28233622b6441576e44070952f6d74.tar.bz2
gentoo-2-4fcb188c6f28233622b6441576e44070952f6d74.zip
Use ${PYTHON_USEDEP} substitution support added to python_gen_cond_dep().
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'virtual/python-futures')
-rw-r--r--virtual/python-futures/ChangeLog5
-rw-r--r--virtual/python-futures/python-futures-0.ebuild6
2 files changed, 6 insertions, 5 deletions
diff --git a/virtual/python-futures/ChangeLog b/virtual/python-futures/ChangeLog
index 56fa0fb1d780..2534888aeeff 100644
--- a/virtual/python-futures/ChangeLog
+++ b/virtual/python-futures/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for virtual/python-futures
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/ChangeLog,v 1.2 2014/04/03 02:02:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/ChangeLog,v 1.3 2014/04/19 18:02:54 mgorny Exp $
+
+ 19 Apr 2014; Michał Górny <mgorny@gentoo.org> python-futures-0.ebuild:
+ Use ${PYTHON_USEDEP} substitution support added to python_gen_cond_dep().
03 Apr 2014; Tim Harder <radhermit@gentoo.org> python-futures-0.ebuild:
Add python3_4 support.
diff --git a/virtual/python-futures/python-futures-0.ebuild b/virtual/python-futures/python-futures-0.ebuild
index 82654523cb09..c677244262ff 100644
--- a/virtual/python-futures/python-futures-0.ebuild
+++ b/virtual/python-futures/python-futures-0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/python-futures-0.ebuild,v 1.2 2014/04/03 02:02:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-futures/python-futures-0.ebuild,v 1.3 2014/04/19 18:02:54 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
@@ -16,6 +16,4 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep \
- "dev-python/futures[$(python_gen_usedep 'python2*')]" \
- 'python2*')"
+ $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2*')"