summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-05 19:33:16 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-05 19:33:16 +0000
commit836917948f20a00802db9caaa5ef9ab1ebb9b7e6 (patch)
tree582ecf1803b52b512ee1cc9a16782ecfc58f255f /virtual/python-argparse
parentStable for x86, wrt bug #470648 (diff)
downloadgentoo-2-836917948f20a00802db9caaa5ef9ab1ebb9b7e6.tar.gz
gentoo-2-836917948f20a00802db9caaa5ef9ab1ebb9b7e6.tar.bz2
gentoo-2-836917948f20a00802db9caaa5ef9ab1ebb9b7e6.zip
Clean up after py2.5+3.1 removal. Inline the deps.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'virtual/python-argparse')
-rw-r--r--virtual/python-argparse/ChangeLog6
-rw-r--r--virtual/python-argparse/python-argparse-0.ebuild4
-rw-r--r--virtual/python-argparse/python-argparse-1.ebuild16
3 files changed, 12 insertions, 14 deletions
diff --git a/virtual/python-argparse/ChangeLog b/virtual/python-argparse/ChangeLog
index aa5863f0c7b9..9f2290f53bec 100644
--- a/virtual/python-argparse/ChangeLog
+++ b/virtual/python-argparse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for virtual/python-argparse
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.12 2013/08/07 11:55:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.13 2013/09/05 19:33:16 mgorny Exp $
+
+ 05 Sep 2013; Michał Górny <mgorny@gentoo.org> python-argparse-0.ebuild,
+ python-argparse-1.ebuild:
+ Clean up after py2.5+3.1 removal. Inline the deps.
07 Aug 2013; Michał Górny <mgorny@gentoo.org> python-argparse-0.ebuild,
python-argparse-1.ebuild:
diff --git a/virtual/python-argparse/python-argparse-0.ebuild b/virtual/python-argparse/python-argparse-0.ebuild
index b041c8c43b61..63de114c3c66 100644
--- a/virtual/python-argparse/python-argparse-0.ebuild
+++ b/virtual/python-argparse/python-argparse-0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-0.ebuild,v 1.4 2013/08/07 11:55:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-0.ebuild,v 1.5 2013/09/05 19:33:16 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy1_9 )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
inherit python-r1
DESCRIPTION="A virtual for the Python argparse module"
diff --git a/virtual/python-argparse/python-argparse-1.ebuild b/virtual/python-argparse/python-argparse-1.ebuild
index 0e7f795fd96d..b59de33158ec 100644
--- a/virtual/python-argparse/python-argparse-1.ebuild
+++ b/virtual/python-argparse/python-argparse-1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-1.ebuild,v 1.11 2013/08/07 11:55:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-1.ebuild,v 1.12 2013/09/05 19:33:16 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
inherit python-r1
DESCRIPTION="A virtual for the Python argparse module"
@@ -15,12 +15,6 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
IUSE=""
-setup_globals() {
- local flag
-
- RDEPEND="${PYTHON_DEPS}"
- for flag in python_targets_python{2_5,2_6,3_1}; do
- RDEPEND+=" ${flag}? ( dev-python/argparse[${flag}] )"
- done
-}
-setup_globals
+RDEPEND="${PYTHON_DEPS}
+ python_targets_python2_6? (
+ dev-python/argparse[python_targets_python2_6] )"