summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-14 23:01:10 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-14 23:01:10 +0000
commitfe2c825c6b4b432c0bd13b316939806d5c59980f (patch)
treea8cc6fe5d5c24781fd3fb189a21947effefc8cc7 /sys-process
parentAdd a permission check to nscd init.d #96108 by Paul Ortyl. (diff)
downloadgentoo-2-fe2c825c6b4b432c0bd13b316939806d5c59980f.tar.gz
gentoo-2-fe2c825c6b4b432c0bd13b316939806d5c59980f.tar.bz2
gentoo-2-fe2c825c6b4b432c0bd13b316939806d5c59980f.zip
Move init.d script off of mirrors and into $FILESDIR #96054.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/atop/ChangeLog6
-rw-r--r--sys-process/atop/atop-1.14.ebuild9
-rw-r--r--sys-process/atop/files/atop.rc23
-rw-r--r--sys-process/atop/files/digest-atop-1.141
4 files changed, 31 insertions, 8 deletions
diff --git a/sys-process/atop/ChangeLog b/sys-process/atop/ChangeLog
index ecf8cdb9703f..2562dd57c446 100644
--- a/sys-process/atop/ChangeLog
+++ b/sys-process/atop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/atop
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/ChangeLog,v 1.3 2005/05/07 06:34:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/ChangeLog,v 1.4 2005/06/14 23:01:10 vapier Exp $
+
+ 14 Jun 2005; Mike Frysinger <vapier@gentoo.org> +files/atop.rc,
+ atop-1.14.ebuild:
+ Move init.d script off of mirrors and into $FILESDIR #96054.
*atop-1.14 (07 May 2005)
diff --git a/sys-process/atop/atop-1.14.ebuild b/sys-process/atop/atop-1.14.ebuild
index 8d858ae5f9fd..9f77e4b2daf8 100644
--- a/sys-process/atop/atop-1.14.ebuild
+++ b/sys-process/atop/atop-1.14.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.14.ebuild,v 1.1 2005/05/07 06:34:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.14.ebuild,v 1.2 2005/06/14 23:01:10 vapier Exp $
-ATOP_INIT_VERSION="1.9"
-ATOP_INIT_SCRIPT=${PN}-${ATOP_INIT_VERSION}-initscript
DESCRIPTION="Resource-specific view of processes"
HOMEPAGE="http://www.atcomputing.nl/Tools/atop"
-SRC_URI="http://www.atconsultancy.nl/atop/packages/${P}.tar.gz
- mirror://gentoo/${PN}-${ATOP_INIT_VERSION}-initscript"
+SRC_URI="http://www.atconsultancy.nl/atop/packages/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -21,7 +18,7 @@ src_unpack() {
cd "${S}"
sed -i -e "/^CFLAGS/s: -O : ${CFLAGS} :" Makefile
mv "${S}"/atop.init "${S}"/atop.init.old
- cp "${DISTDIR}/${ATOP_INIT_SCRIPT}" "${S}"/atop.init
+ cp "${FILESDIR}"/atop.rc "${S}"/atop.init
chmod a+rx atop.init
}
diff --git a/sys-process/atop/files/atop.rc b/sys-process/atop/files/atop.rc
new file mode 100644
index 000000000000..8a6b71587029
--- /dev/null
+++ b/sys-process/atop/files/atop.rc
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/files/atop.rc,v 1.1 2005/06/14 23:01:10 vapier Exp $
+
+start(){
+ ebegin "Starting atop"
+ if [ -f /etc/cron.d/atop ] ; then
+ start-stop-daemon --start --quiet --exec /etc/atop/atop.daily
+ eend $?
+ else
+ eend 1 "/etc/cron.d/atop doesnt exist!"
+ fi
+}
+
+stop(){
+ ebegin "Stopping atop"
+ PIDATOP=`ps -lef | grep -- '-w /var/log/atop/atop_' | grep -v grep | awk '{print $4}'`
+ if [ "$PIDATOP" != "" ] ; then
+ kill $PIDATOP
+ fi
+ eend $?
+}
diff --git a/sys-process/atop/files/digest-atop-1.14 b/sys-process/atop/files/digest-atop-1.14
index 7f224e13e017..e835cebb3c17 100644
--- a/sys-process/atop/files/digest-atop-1.14
+++ b/sys-process/atop/files/digest-atop-1.14
@@ -1,2 +1 @@
MD5 51ed85ea8d869568bd4038485c753756 atop-1.14.tar.gz 108748
-MD5 9e1db520318f831ff4f5006dc737eaa7 atop-1.9-initscript 521