summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-11-08 13:21:51 +0000
committerThilo Bangert <bangert@gentoo.org>2010-11-08 13:21:51 +0000
commitbeb0f567a173904f1b7177f1c0fa8b77ee166f50 (patch)
tree624c9d0d9a1556071bbbef0ad614c50acab7a24a /sys-process
parentMove to virtual/jpeg (diff)
downloadgentoo-2-beb0f567a173904f1b7177f1c0fa8b77ee166f50.tar.gz
gentoo-2-beb0f567a173904f1b7177f1c0fa8b77ee166f50.tar.bz2
gentoo-2-beb0f567a173904f1b7177f1c0fa8b77ee166f50.zip
version bump
(Portage version: 2.2_rc99/cvs/Linux i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/cronie/ChangeLog7
-rw-r--r--sys-process/cronie/cronie-1.4.6.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
index fca1c2c727f0..a309936270dc 100644
--- a/sys-process/cronie/ChangeLog
+++ b/sys-process/cronie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/cronie
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.13 2010/08/12 08:21:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.14 2010/11/08 13:21:51 bangert Exp $
+
+*cronie-1.4.6 (08 Nov 2010)
+
+ 08 Nov 2010; Thilo Bangert <bangert@gentoo.org> +cronie-1.4.6.ebuild:
+ version bump
12 Aug 2010; Markus Meier <maekke@gentoo.org> cronie-1.4.4.ebuild:
amd64/x86 stable, bug #329695
diff --git a/sys-process/cronie/cronie-1.4.6.ebuild b/sys-process/cronie/cronie-1.4.6.ebuild
new file mode 100644
index 000000000000..2b98eed20ee5
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.6.ebuild,v 1.1 2010/11/08 13:21:51 bangert Exp $
+
+EAPI="3"
+
+inherit cron eutils pam
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="inotify pam"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" econf \
+ $(use_with inotify ) \
+ $(use_with pam ) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ docrondir
+ fowners root:cron /usr/bin/crontab
+ fperms 2750 /usr/bin/crontab
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.2-initd" cronie
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ dodoc NEWS AUTHORS README
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}