summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-12-22 23:24:25 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-12-22 23:24:25 +0000
commit307e32a95b79cf16bbb85ec0c0e1efa20b50f9cb (patch)
tree863292baae9fd344453dd54ba75a8e5959b3e6b2 /sys-process
parentFix dependencies and avoid forkbomb in test phase (hopefully). Thanks to Thom... (diff)
downloadgentoo-2-307e32a95b79cf16bbb85ec0c0e1efa20b50f9cb.tar.gz
gentoo-2-307e32a95b79cf16bbb85ec0c0e1efa20b50f9cb.tar.bz2
gentoo-2-307e32a95b79cf16bbb85ec0c0e1efa20b50f9cb.zip
Update src_test for minimal kernels without some parts of sysfs.
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/ChangeLog5
-rw-r--r--sys-process/numactl/numactl-2.0.2.ebuild14
2 files changed, 13 insertions, 6 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index 0db441f8f920..31c395e3931f 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/numactl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.12 2009/09/03 06:50:20 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.13 2009/12/22 23:24:25 robbat2 Exp $
+
+ 22 Dec 2009; Robin H. Johnson <robbat2@gentoo.org> numactl-2.0.2.ebuild:
+ Update src_test for minimal kernels without some parts of sysfs.
03 Sep 2009; Christian Faulhammer <fauli@gentoo.org> numactl-2.0.2.ebuild:
stable x86, bug 281486
diff --git a/sys-process/numactl/numactl-2.0.2.ebuild b/sys-process/numactl/numactl-2.0.2.ebuild
index bfa29a3ddcd2..379e8e208e82 100644
--- a/sys-process/numactl/numactl-2.0.2.ebuild
+++ b/sys-process/numactl/numactl-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.2.ebuild,v 1.5 2009/09/03 06:50:20 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.2.ebuild,v 1.6 2009/12/22 23:24:25 robbat2 Exp $
inherit eutils toolchain-funcs
@@ -26,10 +26,14 @@ src_compile() {
}
src_test() {
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- cd test
- ./regress2 || die "regress2 failed!"
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
}
src_install() {