summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-23 19:49:02 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-23 19:49:02 +0000
commit4a14d5a686e5a02f2edfc90adb7aabe2936a0522 (patch)
treee6ae7018265597051e96dac53772f5128706401f /sys-process/numad
parentVersion bumps. Ebuilds by Arfrever. (diff)
downloadgentoo-2-4a14d5a686e5a02f2edfc90adb7aabe2936a0522.tar.gz
gentoo-2-4a14d5a686e5a02f2edfc90adb7aabe2936a0522.tar.bz2
gentoo-2-4a14d5a686e5a02f2edfc90adb7aabe2936a0522.zip
Fix building with SYMLINK_LIB=no #505760 by Georgi Georgiev. Sync the non-9999 and 9999 ebuild versions.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-process/numad')
-rw-r--r--sys-process/numad/ChangeLog9
-rw-r--r--sys-process/numad/files/numad-0.5-ldlibs.patch34
-rw-r--r--sys-process/numad/numad-0.5-r2.ebuild44
-rw-r--r--sys-process/numad/numad-9999.ebuild13
4 files changed, 91 insertions, 9 deletions
diff --git a/sys-process/numad/ChangeLog b/sys-process/numad/ChangeLog
index eb4dfb533ffc..807b544b3d8e 100644
--- a/sys-process/numad/ChangeLog
+++ b/sys-process/numad/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/numad
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/ChangeLog,v 1.6 2014/01/20 07:50:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/ChangeLog,v 1.7 2014/04/23 19:49:02 vapier Exp $
+
+*numad-0.5-r2 (23 Apr 2014)
+
+ 23 Apr 2014; Mike Frysinger <vapier@gentoo.org> +files/numad-0.5-ldlibs.patch,
+ +numad-0.5-r2.ebuild, numad-9999.ebuild:
+ Fix building with SYMLINK_LIB=no #505760 by Georgi Georgiev. Sync the non-9999
+ and 9999 ebuild versions.
*numad-0.5-r1 (20 Jan 2014)
diff --git a/sys-process/numad/files/numad-0.5-ldlibs.patch b/sys-process/numad/files/numad-0.5-ldlibs.patch
new file mode 100644
index 000000000000..d124e32e9ee4
--- /dev/null
+++ b/sys-process/numad/files/numad-0.5-ldlibs.patch
@@ -0,0 +1,34 @@
+From 9eb3cc5c51d846c8c8b750a4eb55545d7b5fea6c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 23 Apr 2014 15:41:26 -0400
+Subject: [PATCH] use LDLIBS for linker flags
+
+When you put -lfoo into the dependency line of make, it forces it to
+search /lib and /usr/lib for files to link against. This can cause
+problems when trying to cross-compile or build for different ABIs.
+Use the standard LDLIBS variable instead.
+
+URL: https://bugs.gentoo.org/505760
+Reported-by: Georgi Georgiev <chutzimir@gmail.com>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f3838b4..f2e9a6e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -31,7 +31,8 @@ docdir := ${prefix}/share/doc
+
+ all: numad
+
+-numad: numad.o -lpthread
++LDLIBS := -lpthread
++numad: numad.o
+
+ AR ?= ar
+ RANLIB ?= ranlib
+--
+1.9.2
+
diff --git a/sys-process/numad/numad-0.5-r2.ebuild b/sys-process/numad/numad-0.5-r2.ebuild
new file mode 100644
index 000000000000..a1db5c2cbb2a
--- /dev/null
+++ b/sys-process/numad/numad-0.5-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/numad-0.5-r2.ebuild,v 1.1 2014/04/23 19:49:02 vapier Exp $
+
+EAPI=5
+
+inherit linux-info toolchain-funcs eutils
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ inherit git-2
+else
+ HASH="334278ff3d774d105939743436d7378a189e8693"
+ SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=${HASH};sf=tbz2 -> numad-0.5-${HASH:0:7}.tar.bz2"
+ KEYWORDS="~amd64 -arm -s390 ~x86"
+ S="${WORKDIR}/${PN}-${HASH:0:7}"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
+ epatch "${FILESDIR}"/${PN}-0.5-ldlibs.patch #505760
+ tc-export CC
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index c80d2bb32736..3676e6f2ccdb 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/numad-9999.ebuild,v 1.3 2014/01/20 07:50:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/numad-9999.ebuild,v 1.4 2014/04/23 19:49:02 vapier Exp $
EAPI=5
-inherit git-r3 linux-info toolchain-funcs
+inherit linux-info toolchain-funcs eutils
-if [[ ${PV} = "9999" ]]; then
- inherit git-2
+if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
- KEYWORDS=""
+ inherit git-2
else
SRC_URI=""
KEYWORDS="~amd64 ~x86 -arm -s390"
@@ -25,9 +24,7 @@ IUSE=""
CONFIG_CHECK="~NUMA ~CPUSETS"
src_prepare() {
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${FILESDIR}" \
- epatch
-
+ epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
tc-export CC
}