summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2006-12-14 11:13:54 +0000
committerWolfram Schlich <wschlich@gentoo.org>2006-12-14 11:13:54 +0000
commit6984ca3f3982a1efddda7007ce066b9245b3e804 (patch)
treeedf7b5a793c07af7cf05a4a5714ce09becd9dd71 /sys-process/htop/htop-0.6.5.ebuild
parentUnconditionally installing udev-rules due to Bug #158114. (diff)
downloadgentoo-2-6984ca3f3982a1efddda7007ce066b9245b3e804.tar.gz
gentoo-2-6984ca3f3982a1efddda7007ce066b9245b3e804.tar.bz2
gentoo-2-6984ca3f3982a1efddda7007ce066b9245b3e804.zip
version bump
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'sys-process/htop/htop-0.6.5.ebuild')
-rw-r--r--sys-process/htop/htop-0.6.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-process/htop/htop-0.6.5.ebuild b/sys-process/htop/htop-0.6.5.ebuild
new file mode 100644
index 000000000000..115e952ddc10
--- /dev/null
+++ b/sys-process/htop/htop-0.6.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.6.5.ebuild,v 1.1 2006/12/14 11:13:54 wschlich Exp $
+
+inherit debug flag-o-matic
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+DEPEND="sys-libs/ncurses"
+
+src_compile() {
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}