summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-12-18 22:36:34 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-12-18 22:36:34 +0000
commitd644faf9c0aad5ad221263f28baf5358eab87967 (patch)
tree59cc0174b68f989cbc2bff44e7639b3b06a0060a /sys-process/cronie
parentgeierlein bump (diff)
downloadgentoo-2-d644faf9c0aad5ad221263f28baf5358eab87967.tar.gz
gentoo-2-d644faf9c0aad5ad221263f28baf5358eab87967.tar.bz2
gentoo-2-d644faf9c0aad5ad221263f28baf5358eab87967.zip
Version bump (bug #447772). Fixed QA warning about missing user.eclass
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/ChangeLog8
-rw-r--r--sys-process/cronie/cronie-1.4.8-r1.ebuild4
-rw-r--r--sys-process/cronie/cronie-1.4.8.ebuild6
-rw-r--r--sys-process/cronie/cronie-1.4.9.ebuild71
4 files changed, 83 insertions, 6 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
index f46cc7085a91..9279c561c59b 100644
--- a/sys-process/cronie/ChangeLog
+++ b/sys-process/cronie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/cronie
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.24 2012/04/06 18:26:25 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.25 2012/12/18 22:36:34 polynomial-c Exp $
+
+*cronie-1.4.9 (18 Dec 2012)
+
+ 18 Dec 2012; Lars Wendler <polynomial-c@gentoo.org> cronie-1.4.8.ebuild,
+ cronie-1.4.8-r1.ebuild, +cronie-1.4.9.ebuild:
+ Version bump (bug #447772). Fixed QA warning about missing user.eclass.
06 Apr 2012; <swift@gentoo.org> cronie-1.4.8-r1.ebuild:
Toggling SELinux support through USE=selinux (bug #403293)
diff --git a/sys-process/cronie/cronie-1.4.8-r1.ebuild b/sys-process/cronie/cronie-1.4.8-r1.ebuild
index 28642e348f8e..eafb54b9dcf1 100644
--- a/sys-process/cronie/cronie-1.4.8-r1.ebuild
+++ b/sys-process/cronie/cronie-1.4.8-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.8-r1.ebuild,v 1.4 2012/04/06 18:26:25 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.8-r1.ebuild,v 1.5 2012/12/18 22:36:34 polynomial-c Exp $
EAPI="3"
-inherit cron eutils pam
+inherit cron eutils pam user
DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
diff --git a/sys-process/cronie/cronie-1.4.8.ebuild b/sys-process/cronie/cronie-1.4.8.ebuild
index 7d5c3bf0b483..897f56386300 100644
--- a/sys-process/cronie/cronie-1.4.8.ebuild
+++ b/sys-process/cronie/cronie-1.4.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.8.ebuild,v 1.5 2011/10/27 22:42:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.8.ebuild,v 1.6 2012/12/18 22:36:34 polynomial-c Exp $
EAPI="3"
-inherit cron eutils pam
+inherit cron eutils pam user
DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
diff --git a/sys-process/cronie/cronie-1.4.9.ebuild b/sys-process/cronie/cronie-1.4.9.ebuild
new file mode 100644
index 000000000000..32fa7f0d1076
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.9.ebuild,v 1.1 2012/12/18 22:36:34 polynomial-c Exp $
+
+EAPI="5"
+
+inherit cron eutils pam user
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="anacron inotify pam selinux"
+
+DEPEND="pam? ( virtual/pam )
+ anacron? ( !sys-process/anacron )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" econf \
+ $(use_with inotify) \
+ $(use_with pam) \
+ $(use_with selinux) \
+ $(use_enable anacron) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ insinto /etc/conf.d
+ newins "${S}"/crond.sysconfig ${PN}
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ if use anacron ; then
+ keepdir /var/spool/anacron
+ fowners root:cron /var/spool/anacron
+ fperms 0750 /var/spool/anacron
+
+ insinto /etc
+
+ newinitd "${FILESDIR}"/anacron-1.0-initd anacron
+ fi
+
+ dodoc AUTHORS README contrib/*
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}