summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-01-22 17:50:30 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-01-22 17:50:30 +0000
commita41b646c1c951e57234036bd89a7d6da08f6d96c (patch)
treeff093218bb792ac55a403b75de6b209cc107b87b /sys-process/cronie/cronie-1.4.9-r2.ebuild
parentversion bump (bug #452274) (diff)
downloadgentoo-2-a41b646c1c951e57234036bd89a7d6da08f6d96c.tar.gz
gentoo-2-a41b646c1c951e57234036bd89a7d6da08f6d96c.tar.bz2
gentoo-2-a41b646c1c951e57234036bd89a7d6da08f6d96c.zip
Fixed location of anacron spool directory (bug #453548)
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process/cronie/cronie-1.4.9-r2.ebuild')
-rw-r--r--sys-process/cronie/cronie-1.4.9-r2.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/sys-process/cronie/cronie-1.4.9-r2.ebuild b/sys-process/cronie/cronie-1.4.9-r2.ebuild
new file mode 100644
index 000000000000..8c9b9fe13961
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.9-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.9-r2.ebuild,v 1.1 2013/01/22 17:50:30 polynomial-c Exp $
+
+EAPI="5"
+
+inherit cron eutils pam user
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="amd64 arm ~sparc ~x86"
+IUSE="anacron inotify pam selinux"
+
+DEPEND="pam? ( virtual/pam )
+ anacron? ( !sys-process/anacron )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" \
+ ANACRON_SPOOL_DIR="/var/spool/anacron" \
+ econf \
+ $(use_with inotify) \
+ $(use_with pam) \
+ $(use_with selinux) \
+ $(use_enable anacron) \
+ --with-syscrontab \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ insinto /etc/conf.d
+ newins "${S}"/crond.sysconfig ${PN}
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ if use anacron ; then
+ keepdir /var/spool/anacron
+ fowners root:cron /var/spool/anacron
+ fperms 0750 /var/spool/anacron
+
+ insinto /etc
+
+ newinitd "${FILESDIR}"/anacron-1.0-initd anacron
+ fi
+
+ dodoc AUTHORS README contrib/*
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}