summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-11-30 19:22:25 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-11-30 19:22:25 +0000
commit2e495d75a039dde460d63967c1ef2feb740f8b79 (patch)
treeb8b58fa6f4805cdbcc9587f4949cde6256b68547 /sys-power
parent[bump] dev-perl/HTTP-BrowserDetect-1.370.0 (diff)
downloadgentoo-2-2e495d75a039dde460d63967c1ef2feb740f8b79.tar.gz
gentoo-2-2e495d75a039dde460d63967c1ef2feb740f8b79.tar.bz2
gentoo-2-2e495d75a039dde460d63967c1ef2feb740f8b79.zip
Version bump, changes opts to extra_started_commands in init.d script, see bug #385643.
(Portage version: 2.1.10.38/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog9
-rw-r--r--sys-power/hibernate-script/hibernate-script-2.0-r4.ebuild73
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index ea1d57f10301..2e8fbfec7add 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.89 2011/02/06 18:23:45 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.90 2011/11/30 19:22:25 nelchael Exp $
+
+*hibernate-script-2.0-r4 (30 Nov 2011)
+
+ 30 Nov 2011; Krzysztof Pawlik <nelchael@gentoo.org>
+ +hibernate-script-2.0-r4.ebuild:
+ Version bump, changes opts to extra_started_commands in init.d script, see
+ bug #385643.
*hibernate-script-2.0-r3 (06 Feb 2011)
diff --git a/sys-power/hibernate-script/hibernate-script-2.0-r4.ebuild b/sys-power/hibernate-script/hibernate-script-2.0-r4.ebuild
new file mode 100644
index 000000000000..9b40356e2f08
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-2.0-r4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-2.0-r4.ebuild,v 1.1 2011/11/30 19:22:25 nelchael Exp $
+
+EAPI=2
+
+inherit eutils
+
+PATCH_VERSION="2"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.tuxonice.net/"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND="!<media-gfx/splashutils-1.5.2"
+
+src_prepare() {
+ epatch "${WORKDIR}/${PV}/"*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ chmod 644 \
+ "${D}/etc/hibernate/"*.conf \
+ "${D}/etc/hibernate/blacklisted-modules" \
+ "${D}/usr/share/hibernate/scriptlets.d/"* \
+ "${D}/usr/share/hibernate/tuxonice-binary-signature.bin" \
+ || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate suspend"
+ elog "images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+}