summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-08-08 03:04:35 +0000
committerRick Farina <zerochaos@gentoo.org>2013-08-08 03:04:35 +0000
commitee3881cc466e3aa2a7533c1ecfe9b3431fbf61a7 (patch)
treecab9a4fec42b25808730f7969ba2dc05023c7f84 /sys-power/powertop
parentVersion bump to 2.0.14. (diff)
downloadgentoo-2-ee3881cc466e3aa2a7533c1ecfe9b3431fbf61a7.tar.gz
gentoo-2-ee3881cc466e3aa2a7533c1ecfe9b3431fbf61a7.tar.bz2
gentoo-2-ee3881cc466e3aa2a7533c1ecfe9b3431fbf61a7.zip
fix deprecated kernel config check
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'sys-power/powertop')
-rw-r--r--sys-power/powertop/ChangeLog5
-rw-r--r--sys-power/powertop/powertop-2.4.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index dd3bdf8ff03e..386e1601cbdd 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.84 2013/07/24 14:09:16 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.85 2013/08/08 03:04:35 zerochaos Exp $
+
+ 08 Aug 2013; Rick Farina <zerochaos@gentoo.org> powertop-2.4.ebuild:
+ fix deprecated kernel config check
*powertop-2.4 (24 Jul 2013)
diff --git a/sys-power/powertop/powertop-2.4.ebuild b/sys-power/powertop/powertop-2.4.ebuild
index 2dda29eab378..0492b728b1a1 100644
--- a/sys-power/powertop/powertop-2.4.ebuild
+++ b/sys-power/powertop/powertop-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.4.ebuild,v 1.1 2013/07/24 14:09:16 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.4.ebuild,v 1.2 2013/08/08 03:04:35 zerochaos Exp $
EAPI="5"
@@ -54,7 +54,6 @@ pkg_setup() {
~FTRACE
~BLK_DEV_IO_TRACE
~TIMER_STATS
- ~EVENT_POWER_TRACING_DEPRECATED
~TRACING
"
ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
@@ -70,7 +69,6 @@ pkg_setup() {
ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
linux-info_pkg_setup
if linux_config_exists; then
@@ -81,6 +79,11 @@ pkg_setup() {
check_extra_config
fi
fi
+ if kernel_is -lt 3 9 0; then
+ CONFIG_CHECK="~EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ check_extra_config
+ fi
fi
}