summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-06-09 17:20:17 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-06-09 17:20:17 +0000
commitd3fca8c5f8b07e2c97abb62162d9e30fa72fa109 (patch)
tree9d1b24e21405d2ff8ba9f3bde69fc0a535dc3ea5 /sys-libs
parentVersion dump. (diff)
downloadgentoo-2-d3fca8c5f8b07e2c97abb62162d9e30fa72fa109.tar.gz
gentoo-2-d3fca8c5f8b07e2c97abb62162d9e30fa72fa109.tar.bz2
gentoo-2-d3fca8c5f8b07e2c97abb62162d9e30fa72fa109.zip
New Version
(Portage version: 2.1.5.4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/ChangeLog9
-rw-r--r--sys-libs/newlib/newlib-1.16.0.ebuild74
2 files changed, 81 insertions, 2 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index daf29f5910ca..5300379803ca 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/newlib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.10 2007/10/25 06:24:23 lu_zero Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.11 2008/06/09 17:20:17 lu_zero Exp $
+
+*newlib-1.16.0 (09 Jun 2008)
+
+ 09 Jun 2008; Luca Barbato <lu_zero@gentoo.org> +newlib-1.16.0.ebuild:
+ New Version
*newlib-1.16.0_pre20071025 (25 Oct 2007)
diff --git a/sys-libs/newlib/newlib-1.16.0.ebuild b/sys-libs/newlib/newlib-1.16.0.ebuild
new file mode 100644
index 000000000000..5cfbd1a6199a
--- /dev/null
+++ b/sys-libs/newlib/newlib-1.16.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.16.0.ebuild,v 1.1 2008/06/09 17:20:17 lu_zero Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+# Handle the case where we want newlib on glibc ...
+if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
+ export CTARGET=${CHOST%%-*}-pc-linux-newlib
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="http://sourceware.org/newlib/"
+SRC_URI="ftp://sources.redhat.com/pub/newlib/${P}.tar.gz"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls threads unicode"
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND=""
+
+NEWLIBBUILD="${WORKDIR}/build"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${NEWLIBBUILD}"
+}
+
+src_compile() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ local myconf=""
+ # hardwired to avoid breakages
+ [[ $(tc-is-softfloat) != "no" ]] \
+ && myconf="--disable-newlib-hw-fp" \
+ || myconf="--enable-newlib-hw-fp"
+ [[ ${CTARGET} == "spu" ]] \
+ && myconf="${myconf} --disable-threads" \
+ || myconf="${myconf} $(use_enable threads)"
+
+ cd "${NEWLIBBUILD}"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
+# env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ # minor hack to keep things clean
+ rm -fR "${D}"/usr/share/info
+ rm -fR "${D}"/usr/info
+}