summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-03 08:42:30 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-03 08:42:30 +0000
commit8409e78742467281377b8466132a5debf1fe7f57 (patch)
treeb18bf7014531662a18e6bde33d325f8d2bb2bffb /sys-libs
parentKeep just empty keywords not -*. Shuts up repoman. (diff)
downloadgentoo-2-8409e78742467281377b8466132a5debf1fe7f57.tar.gz
gentoo-2-8409e78742467281377b8466132a5debf1fe7f57.tar.bz2
gentoo-2-8409e78742467281377b8466132a5debf1fe7f57.zip
Update to git2 eclass too.
(Portage version: 2.2.0_alpha52/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/suacomp/ChangeLog5
-rw-r--r--sys-libs/suacomp/suacomp-9999.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-libs/suacomp/ChangeLog b/sys-libs/suacomp/ChangeLog
index a566c407d833..063cb03ec887 100644
--- a/sys-libs/suacomp/ChangeLog
+++ b/sys-libs/suacomp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/suacomp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/suacomp/ChangeLog,v 1.11 2011/09/03 08:40:58 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/suacomp/ChangeLog,v 1.12 2011/09/03 08:42:30 scarabeus Exp $
+
+ 03 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> suacomp-9999.ebuild:
+ Update to git2 eclass too.
03 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> suacomp-9999.ebuild:
Keep just empty keywords not -*. Shuts up repoman.
diff --git a/sys-libs/suacomp/suacomp-9999.ebuild b/sys-libs/suacomp/suacomp-9999.ebuild
index ffe62d000771..54f83463e82d 100644
--- a/sys-libs/suacomp/suacomp-9999.ebuild
+++ b/sys-libs/suacomp/suacomp-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/suacomp/suacomp-9999.ebuild,v 1.4 2011/09/03 08:40:58 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/suacomp/suacomp-9999.ebuild,v 1.5 2011/09/03 08:42:30 scarabeus Exp $
-EAPI=3
+EAPI=4
-inherit toolchain-funcs flag-o-matic git
+inherit toolchain-funcs flag-o-matic git-2
DESCRIPTION="library wrapping the interix lib-c to make it less buggy."
HOMEPAGE="http://suacomp.sf.net"
@@ -42,12 +42,12 @@ pkg_setup() {
}
src_compile() {
- emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}" || die "emake failed"
+ emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}"
}
src_install() {
emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
- CFLAGS="${CFLAGS}" || die "emake install failed"
+ CFLAGS="${CFLAGS}"
}
src_test() {
@@ -56,5 +56,5 @@ src_test() {
use debug && v="TEST_VERBOSE=1"
use debug && export SUACOMP_DEBUG_OUT=stderr
- emake check $(get_opts) ${v} || die "emake check failed"
+ emake check $(get_opts) ${v}
}