summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-21 21:38:03 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-21 21:38:03 +0000
commit6118596ccd805fc017ecc72529d419a25715a5f1 (patch)
tree35c3b12f2ead1d866d337e36c32e5df0528def5d /sys-libs
parentold (diff)
downloadgentoo-2-6118596ccd805fc017ecc72529d419a25715a5f1.tar.gz
gentoo-2-6118596ccd805fc017ecc72529d419a25715a5f1.tar.bz2
gentoo-2-6118596ccd805fc017ecc72529d419a25715a5f1.zip
Version bump #259830 by Lars (Polynomial-C).
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog8
-rw-r--r--sys-libs/readline/files/readline-6.0-rlfe-build.patch21
-rw-r--r--sys-libs/readline/readline-6.0.ebuild90
3 files changed, 118 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 8d8726915ed6..90b3c6eeb674 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.124 2009/02/21 21:31:57 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.125 2009/02/21 21:38:02 vapier Exp $
+
+*readline-6.0 (21 Feb 2009)
+
+ 21 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/readline-6.0-rlfe-build.patch, +readline-6.0.ebuild:
+ Version bump #259830 by Lars (Polynomial-C).
21 Feb 2009; Ferris McCormick <fmccor@gentoo.org> readline-5.2_p13.ebuild:
Sparc really stable this time --- Bug #255707.
diff --git a/sys-libs/readline/files/readline-6.0-rlfe-build.patch b/sys-libs/readline/files/readline-6.0-rlfe-build.patch
new file mode 100644
index 000000000000..cc4ca97ee849
--- /dev/null
+++ b/sys-libs/readline/files/readline-6.0-rlfe-build.patch
@@ -0,0 +1,21 @@
+--- a/examples/rlfe/Makefile.in
++++ b/examples/rlfe/Makefile.in
+@@ -55,7 +55,7 @@ rlfe-$(VERSION).tar.gz:
+ tar czf $@ $(CFILES) $(HFILES) $(EXTRA_DIST)
+
+ .c.o:
+- $(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(DEFS) $(OPTIONS) $(CFLAGS) $<
++ $(CC) -c -I. -I$(srcdir) $(CPPFLAGS) $(M_CFLAGS) $(DEFS) $(OPTIONS) $(CFLAGS) $<
+
+ install_bin: .version screen
+ -if [ -f $(DESTDIR)$(bindir)/$(SCREEN) ] && [ ! -f $(DESTDIR)$(bindir)/$(SCREEN).old ]; \
+@@ -170,6 +170,9 @@ depend.in: $(CFILES) term.h
+ for i in $(CFILES); do echo $$i; $(CPP_DEPEND) $$i >> tmp_make; done
+ mv tmp_make Makefile.in
+
++Makefile: $(srcdir)/Makefile.in
++ ./config.status
++
+ ###############################################################################
+
+ ### Dependencies:
diff --git a/sys-libs/readline/readline-6.0.ebuild b/sys-libs/readline/readline-6.0.ebuild
new file mode 100644
index 000000000000..24a7a780a141
--- /dev/null
+++ b/sys-libs/readline/readline-6.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.0.ebuild,v 1.1 2009/02/21 21:38:02 vapier Exp $
+
+inherit autotools eutils multilib toolchain-funcs flag-o-matic
+
+# Official patches
+# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+[[ ${PV} != *_p* ]] && PLEVEL=0
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/readline/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+ # Official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
+ epatch "${FILESDIR}"/${PN}-6.0-rlfe-build.patch #151174
+ epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
+
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+
+ # the bundled rlfe had its configure.in updated, but no one actually
+ # ran autoconf to have the configure file updated
+ ln -s ../.. examples/rlfe/readline
+ cd examples/rlfe
+ eautoconf
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+
+ econf --with-curses || die
+ emake || die
+
+ cd examples/rlfe
+ append-ldflags -Lreadline
+ econf || die
+ emake || die "make rlfe failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ gen_usr_ldscript -a readline history #4411
+
+ dobin examples/rlfe/rlfe || die
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+
+pkg_preinst() {
+ preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
+}