summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-15 21:23:06 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-15 21:23:06 +0000
commit1ab786895c144e8c739df24da89c26eace2e5635 (patch)
tree2bea289f4c982ba0ae90e0f79870827d3c40a44d /sys-libs
parentFix built_with_use atom; bug #259055 (diff)
downloadgentoo-2-1ab786895c144e8c739df24da89c26eace2e5635.tar.gz
gentoo-2-1ab786895c144e8c739df24da89c26eace2e5635.tar.bz2
gentoo-2-1ab786895c144e8c739df24da89c26eace2e5635.zip
Fix building on uClibc systems #222099 by Sergey Dryabzhinsky.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gpm/ChangeLog7
-rw-r--r--sys-libs/gpm/files/0001-daemon-use-sys-ioctl.h-for-ioctl.patch31
-rw-r--r--sys-libs/gpm/gpm-1.20.5.ebuild3
-rw-r--r--sys-libs/gpm/gpm-1.20.6.ebuild3
4 files changed, 41 insertions, 3 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 17831b0d7879..4546cb06f504 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.77 2009/02/15 21:06:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.78 2009/02/15 21:23:06 vapier Exp $
+
+ 15 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/0001-daemon-use-sys-ioctl.h-for-ioctl.patch, gpm-1.20.5.ebuild,
+ gpm-1.20.6.ebuild:
+ Fix building on uClibc systems #222099 by Sergey Dryabzhinsky.
*gpm-1.20.6 (15 Feb 2009)
diff --git a/sys-libs/gpm/files/0001-daemon-use-sys-ioctl.h-for-ioctl.patch b/sys-libs/gpm/files/0001-daemon-use-sys-ioctl.h-for-ioctl.patch
new file mode 100644
index 000000000000..b6c7809c0eb5
--- /dev/null
+++ b/sys-libs/gpm/files/0001-daemon-use-sys-ioctl.h-for-ioctl.patch
@@ -0,0 +1,31 @@
+From b184152761d8a4dbf73adcffaddac85709949c2f Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 15 Feb 2009 16:16:51 -0500
+Subject: [PATCH] daemon: use sys/ioctl.h for ioctl()
+
+Including stropts.h for the ioctl() prototype is weird and breaks some
+systems that do not implement stropts.h. Use sys/ioctl.h like normal.
+
+URL: http://bugs.gentoo.org/222099
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Reported-by: Sergey Dryabzhinsky <sergey.dryabzhinsky@gmail.com>
+---
+ src/daemon/open_console.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/daemon/open_console.c b/src/daemon/open_console.c
+index 27b62e2..98297c9 100644
+--- a/src/daemon/open_console.c
++++ b/src/daemon/open_console.c
+@@ -21,7 +21,7 @@
+
+ #include <fcntl.h> /* open and co. */
+ #include <sys/stat.h> /* stat() */
+-#include <stropts.h> /* ioctl */
++#include <sys/ioctl.h> /* ioctl */
+
+ /* Linux specific (to be outsourced in gpm2 */
+ #include <linux/serial.h> /* for serial console check */
+--
+1.6.1.3
+
diff --git a/sys-libs/gpm/gpm-1.20.5.ebuild b/sys-libs/gpm/gpm-1.20.5.ebuild
index dc6f8bd78117..b216d1ca0019 100644
--- a/sys-libs/gpm/gpm-1.20.5.ebuild
+++ b/sys-libs/gpm/gpm-1.20.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.5.ebuild,v 1.7 2009/01/21 20:25:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.5.ebuild,v 1.8 2009/02/15 21:23:06 vapier Exp $
# emacs support disabled due to Bug 99533
@@ -23,6 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.20.5-abi.patch
+ epatch "${FILESDIR}"/0001-daemon-use-sys-ioctl.h-for-ioctl.patch #222099
}
src_compile() {
diff --git a/sys-libs/gpm/gpm-1.20.6.ebuild b/sys-libs/gpm/gpm-1.20.6.ebuild
index 65cacbbf05ab..7877b5f02f8e 100644
--- a/sys-libs/gpm/gpm-1.20.6.ebuild
+++ b/sys-libs/gpm/gpm-1.20.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.6.ebuild,v 1.1 2009/02/15 21:06:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.6.ebuild,v 1.2 2009/02/15 21:23:06 vapier Exp $
# emacs support disabled due to Bug 99533
@@ -23,6 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.20.5-abi.patch
+ epatch "${FILESDIR}"/0001-daemon-use-sys-ioctl.h-for-ioctl.patch #222099
}
src_compile() {