summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-10-30 17:04:34 +0000
committerMike Frysinger <vapier@gentoo.org>2013-10-30 17:04:34 +0000
commit1721f57a6c1784325befd179f39a9bd508e75633 (patch)
tree47b52128bd35f2eb2f5c9f71afe43f008de41ea5 /sys-libs
parentBackport fix for kde bug 323762 (diff)
downloadgentoo-2-1721f57a6c1784325befd179f39a9bd508e75633.tar.gz
gentoo-2-1721f57a6c1784325befd179f39a9bd508e75633.tar.bz2
gentoo-2-1721f57a6c1784325befd179f39a9bd508e75633.zip
Add ifunc checks for arm/hppa/ppc/s390.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog5
-rw-r--r--sys-libs/glibc/files/eblits/common.eblit12
2 files changed, 12 insertions, 5 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index fed19659cff9..2c4697a442a7 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.952 2013/10/06 08:51:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.953 2013/10/30 17:04:34 vapier Exp $
+
+ 30 Oct 2013; Mike Frysinger <vapier@gentoo.org> files/eblits/common.eblit:
+ Add ifunc checks for arm/hppa/ppc/s390.
06 Oct 2013; Pacho Ramos <pacho@gentoo.org> +files/nscd.service,
+files/nscd.tmpfilesd, files/eblits/src_install.eblit, glibc-2.16.0.ebuild,
diff --git a/sys-libs/glibc/files/eblits/common.eblit b/sys-libs/glibc/files/eblits/common.eblit
index 0fbfe9cd01c5..e4f9ce92b6d1 100644
--- a/sys-libs/glibc/files/eblits/common.eblit
+++ b/sys-libs/glibc/files/eblits/common.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.30 2013/06/29 03:22:32 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.31 2013/10/30 17:04:33 vapier Exp $
alt_prefix() {
is_crosscompile && echo /usr/${CTARGET}
@@ -249,9 +249,13 @@ use_multiarch() {
local bver nver
bver=$($(tc-getLD ${CTARGET}) -v | sed -n -r '1{s:[^0-9]*::;s:^([0-9.]*).*:\1:;p}')
case $(tc-arch ${CTARGET}) in
- amd64|x86) nver="2.20" ;;
- sparc) nver="2.21" ;;
- *) return 1 ;;
+ amd64|x86) nver="2.20" ;;
+ arm) nver="2.22" ;;
+ hppa) nver="2.23" ;;
+ ppc|ppc64) nver="2.20" ;;
+ s390) nver="2.23" ;;
+ sparc) nver="2.21" ;;
+ *) return 1 ;;
esac
version_is_at_least ${nver} ${bver}
}