summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2014-04-28 19:38:15 +0000
committerSven Vermeulen <swift@gentoo.org>2014-04-28 19:38:15 +0000
commit0d341d6fd461b378c3fad6b164862f75982d8fad (patch)
tree58b71f2872d3e385a4dda70b297e5a99f54687e0 /sys-libs
parentVersion bump (diff)
downloadgentoo-2-0d341d6fd461b378c3fad6b164862f75982d8fad.tar.gz
gentoo-2-0d341d6fd461b378c3fad6b164862f75982d8fad.tar.bz2
gentoo-2-0d341d6fd461b378c3fad6b164862f75982d8fad.zip
2.3-rc1 release
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.3_rc1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 12305b1e7d05..daf831002974 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.62 2014/01/20 20:02:17 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.63 2014/04/28 19:38:15 swift Exp $
+
+*libsepol-2.3_rc1 (28 Apr 2014)
+
+ 28 Apr 2014; Sven Vermeulen <swift@gentoo.org> +libsepol-2.3_rc1.ebuild:
+ 2.3-rc1 release
20 Jan 2014; Sven Vermeulen <swift@gentoo.org> -libsepol-2.1.8.ebuild,
-libsepol-2.1.8-r1.ebuild, libsepol-2.2.ebuild:
diff --git a/sys-libs/libsepol/libsepol-2.3_rc1.ebuild b/sys-libs/libsepol/libsepol-2.3_rc1.ebuild
new file mode 100644
index 000000000000..3e168142080a
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.3_rc1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.3_rc1.ebuild,v 1.1 2014/04/28 19:38:15 swift Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs eutils multilib-minimal
+
+MY_P="${P//_/-}"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/2.3-rc1/${MY_P}.tar.gz"
+# http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+# EPATCH_MULTI_MSG="Applying libsepol patches ... " \
+# EPATCH_SUFFIX="patch" \
+# EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+# EPATCH_FORCE="yes" \
+# epatch
+
+ epatch_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export RANLIB;
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake DESTDIR="${D}" install
+}