summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-10 21:56:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-10 21:56:44 +0000
commit0701ca1a64b2a06e994d8df05e5ef1b783b52b35 (patch)
tree70041a7997ae6f0ffab76586a69cd0715dc17abc /sys-libs
parentStable on alpha. (diff)
downloadgentoo-2-0701ca1a64b2a06e994d8df05e5ef1b783b52b35.tar.gz
gentoo-2-0701ca1a64b2a06e994d8df05e5ef1b783b52b35.tar.bz2
gentoo-2-0701ca1a64b2a06e994d8df05e5ef1b783b52b35.zip
Version bump.
(Portage version: 2.0.53)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/files/digest-readline-5.11
-rw-r--r--sys-libs/readline/readline-5.1.ebuild81
3 files changed, 88 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 3a231bf113cd..8ed7452a85d6 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.50 2005/09/10 17:07:07 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.51 2005/12/10 21:56:44 vapier Exp $
+
+*readline-5.1 (10 Dec 2005)
+
+ 10 Dec 2005; Mike Frysinger <vapier@gentoo.org> +readline-5.1.ebuild:
+ Version bump.
10 Sep 2005; Kito <kito@gentoo.org> readline-5.0-r2.ebuild:
~ppc-macos keyword. Keep shlibs in /usr/lib and skip gen_usr_ldscript on
diff --git a/sys-libs/readline/files/digest-readline-5.1 b/sys-libs/readline/files/digest-readline-5.1
new file mode 100644
index 000000000000..69fda4e3389b
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-5.1
@@ -0,0 +1 @@
+MD5 7ee5a692db88b30ca48927a13fd60e46 readline-5.1.tar.gz 2030276
diff --git a/sys-libs/readline/readline-5.1.ebuild b/sys-libs/readline/readline-5.1.ebuild
new file mode 100644
index 000000000000..505041cb069d
--- /dev/null
+++ b/sys-libs/readline/readline-5.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.1.ebuild,v 1.1 2005/12/10 21:56:44 vapier Exp $
+
+inherit eutils multilib
+
+# Official patches
+PLEVEL=""
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/readline/${P}.tar.gz
+ ${PLEVEL//x/mirror://gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd "${S}"
+ for x in ${PLEVEL//x} ; do
+ epatch "${DISTDIR}"/${PN}${PV/\.}-${x}
+ done
+ epatch "${FILESDIR}"/bash-3.0-etc-inputrc.patch
+ epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
+
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+}
+
+src_compile() {
+ # the --libdir= is needed because if lib64 is a directory, it will default
+ # to using that... even if CONF_LIBDIR isnt set or we're using a version
+ # of portage without CONF_LIBDIR support.
+ econf --with-curses --libdir=/usr/$(get_libdir) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /$(get_libdir)
+
+ if ! use userland_Darwin ; then
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ chmod a+rx "${D}"/$(get_libdir)/*.so*
+
+ # Bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ fi
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+
+pkg_preinst() {
+ # Backwards compatibility #29865
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ cp -pPR "${ROOT}"/$(get_libdir)/libreadline.so.4* "${D}"/$(get_libdir)/
+ touch "${D}"/$(get_libdir)/libreadline.so.4*
+ fi
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --soname libreadline.so.4' asap."
+ ewarn "Once you have, you can safely delete /$(get_libdir)/libreadline.so.4*"
+ fi
+}