summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-22 00:27:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-22 00:27:47 +0000
commitf64450a88e577d8b24afa0a2b966b97d1a7005ac (patch)
treec4b703a5cfdd2d3c2979a2bde03cf8d718a2911a /sys-libs/zlib
parentmedia-libs/portaudio slot update. (diff)
downloadgentoo-2-f64450a88e577d8b24afa0a2b966b97d1a7005ac.tar.gz
gentoo-2-f64450a88e577d8b24afa0a2b966b97d1a7005ac.tar.bz2
gentoo-2-f64450a88e577d8b24afa0a2b966b97d1a7005ac.zip
arm/s390 stable #99751
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/zlib-1.2.3.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-libs/zlib/zlib-1.2.3.ebuild b/sys-libs/zlib/zlib-1.2.3.ebuild
index 69f7b188fd1f..32c5cfd32633 100644
--- a/sys-libs/zlib/zlib-1.2.3.ebuild
+++ b/sys-libs/zlib/zlib-1.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3.ebuild,v 1.4 2005/07/21 15:51:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3.ebuild,v 1.5 2005/07/22 00:27:47 vapier Exp $
inherit eutils flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="http://www.gzip.org/zlib/${P}.tar.bz2
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE="build"
RDEPEND=""
@@ -24,17 +24,17 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Make sure we link with glibc at all times
- epatch ${FILESDIR}/${PN}-1.2.1-glibc.patch
+ epatch "${FILESDIR}"/${PN}-1.2.1-glibc.patch
# Needed for Alpha and prelink
- epatch ${FILESDIR}/${PN}-1.2.1-build-fPIC.patch
+ epatch "${FILESDIR}"/${PN}-1.2.1-build-fPIC.patch
# Only export global symbols, bug #32764
- epatch ${FILESDIR}/${PN}-1.2.2-mapfile.patch
+ epatch "${FILESDIR}"/${PN}-1.2.2-mapfile.patch
# The configure script can be kind of dumb #55434
- epatch ${FILESDIR}/${PN}-1.2.1-configure.patch
+ epatch "${FILESDIR}"/${PN}-1.2.1-configure.patch
# fix shared library test on -fPIC dependant archs
- epatch ${FILESDIR}/${PN}-1.2.1-fPIC.patch
+ epatch "${FILESDIR}"/${PN}-1.2.1-fPIC.patch
}
src_compile() {
@@ -43,7 +43,7 @@ src_compile() {
}
src_install() {
- einstall libdir=${D}/$(get_libdir) || die
+ einstall libdir="${D}"/$(get_libdir) || die
rm "${D}"/$(get_libdir)/libz.a
insinto /usr/include
doins zconf.h zlib.h
@@ -63,7 +63,7 @@ src_install() {
# for NFS based /usr
into /
dolib libz.so.${PV}
- ( cd ${D}/$(get_libdir) ; chmod 755 libz.so.* )
+ ( cd "${D}"/$(get_libdir) ; chmod 755 libz.so.* )
dosym libz.so.${PV} /$(get_libdir)/libz.so
dosym libz.so.${PV} /$(get_libdir)/libz.so.1
gen_usr_ldscript libz.so